fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Проброс порта на MikroTik для одного и двух провайдеров

опубликовал от 02 Август, 2016

Сколько было написано инструкций по настройке, а такой простой вещи как проброс порта в MikroTik на нашем сайте не было. Исправил этот недочёт. Рассмотрим сегодня несколько способов публикации вашего сервера в сети интернет на маршрутизаторах MikroTik. Также раскажу про публикацию сервера на двух внешних IP адресах. Есть очень простой способ это сделать не прибегая к маркировке исходящих и входящий соединений.

1. Простой проброс порта если нет статического IP

В самом простом случае проброс порта привязывется к внешнуму интерфейсу In. Interface. Для этого идём в IP/Firewall на вкладку NAT и плюсиком создаём правило:

 

 Цепочка dst-nat, входящий интерфейс ByFly, порт TCP 55555

Если порт на входе равен порту на выходе или пробросить нужно несколько портов одним правилом в поле "To port" можно ничего не писать:

 Из командной строки надо исполнить такой скрипт:

/ip firewall nat
add action=dst-nat chain=dstnat comment=torrent dst-port=55555 in-interface=\
ByFly protocol=tcp to-addresses=10.24.3.2

2. Проброс группы портов если есть статический IP

Если у провайдера выкуплен внешний статический IP правило лучше видоизменить:

Это позволит открывать изнутри сети ресурсы сервера по внешнему IP. Очень полезно для настройки на переносных устройствах которые могут подключаться к серверу как из других сетей так и по Wi-Fi. В данном случае рассмотрен проброс нескольких портов одним правилом: TCP 55555, 80, 21. 86.57.150.15 - внешний IP.

Из коммандной строки следует выполнить:

/ip firewall nat
add action=dst-nat chain=dstnat comment=probros_web_ftp_torrent dst-address=86.57.150.15\
dst-port=55555,21,80 protocol=tcp to-addresses=10.24.3.2

 3. Публикация сервера на 2-ух внешних IP

Для начала следует прописать на сервере второй IP адресс из другой подсети на сетевом интерфейсе:

 Добавляем столько адресов сколько нам нужно:

Идём в IP adresses и добавляем на сетевом интерфейсе ip 10.24.4.1/24 через который будет идти взаимодействие маршрутизатора с сервером:

Сделаем маршрут для второго провайдера с меткой route-1 для этого идём в IP/Route:

Создадим правило согласно которому сеть 10.24.4.0/24 роутится через второго провайдера:

К основному пробросу портов надо добавить проброс порта через второго провайдера:

где 86.57.150.16 IP второго провайдера.

Соответственно пробрасываем на IP 10.24.4.2:

Необходимо сделать также masquerade при обращении к 10.24.4.2 для того чтобы подключение ко второму IP WINDOWS работало:

 Настройка закончена! Теперь сервер доступен c двух внешних IP.

Прочитано 16807 раз Последнее изменение Понедельник, 17 Июль 2017 02:52
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by

Другие материалы с нашего сайта:

2 Комментарии

  • Игорь

    Добрый день!
    подскажите пожалуйста есть роутер Mikrotik RB 951 2n, задача состоит в том чтобы настроить 3 и 4 порт на двух независимых провайдеров, оба провайдера заходят на микротик 1 и 2 порт по DHCP, 1 провайдер шлюз 192.168.1.1 второй 192.168.100.1 как настроить так, чтобы VLAN с сетью 172.200.2.0/24 (3порт) работал через провайдера со шлюзом 192.168.1.1, а VLAN с сетью 172.200.10.0/24 (4порт) работал через провайдера со шлюзом 192.168.100.1 и вообще возможно такое сделать на данной модели. Заранее спасибо!!!

    Ответ: Конечно возможно. Роутинг полиси так называемый надо использовать...

    Игорь   Вторник, 19 Декабрь 2017 13:20
  • Vlad

    Добрый день!

    Адрес 192.168.8.1 - ето адрес чего у Вас?
    Там где Сделаем маршрут для второго провайдера с меткой ....

    Ответ: Это адрес шлюза второго провайдера ....

    Vlad   Среда, 05 Июль 2017 00:44

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
  • bcloud Написал bcloud Июнь 17, 2019 Добрый день! Подскажите, пожалуйста, как решить проблему. У нас на фирме подключили такой модем, все…
  • Нур Написал Нур Апрель 30, 2019 работает на локалке, а по wifi на телефоне не работает
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по настройке маршрутизаторов MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промсвязь
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3
 rss  vk groupe

 

Нравится ли вам наш блог?


Обнаруженная в протоколе Bluetooth дыра позволяет прослушать миллионы устройств
В протоколе Bluetooth обнаружена новая уязвимость. Исследователи Даниель Антониоли (Daniele Antonioli), Нильс Оле Типпенхауэр (Nils Ole Tippenhauer) и Каспер Расмуссен (Kasper Rasmussen) обнаружили,
Власти США могут на 90 дней отложить санкции против Huawei
США уже не скрывают, что запрет на работу с китайской компанией Huawei ― это всего лишь инструмент экономического давления на власти Поднебесной. Всё начиналось с заявок об угрозе национальной
Разработчики говорят, что ограничения Apple на отслеживание местоположения являются антиконкурентными
Группа разработчиков приложений для iOS занялась новыми политиками конфиденциальности Apple, которые дебютируют вместе с iOS 13 этой осенью. Они заявляют, что ограничения отслеживания местоположения,
ФАС оштрафует Google за «ненадлежащую» контекстную рекламу финансовых услуг
Федеральная антимонопольная служба России (ФАС России) признала контекстную рекламу финансовых услуг в сервисе Google AdWords нарушающей требования Закона о рекламе.  Нарушение было
iPhone 11 скорее всего выйдет 10 сентября
10 сентября Apple скорее всего представит минимум три новых смартфона. Об этом говорит картинка найденая в IOS 13 Beta. Скорее всего, их назовут iPhone 11, iPhone 11 Pro и iPhone 11 Pro Max.
Нехватка процессоров Intel сохранится до 2020 года
По данным тайваньского ODM-производителя Compal Electronics, нехватка процессоров Intel продолжится во втором полугодии этого года и сохранится до начала 2020 года. В конце прошлого года Intel
Apple будет враждебно относиться к сайтам, нарушающим правила конфиденциальности Safari
Компания Apple заняла жёсткую позицию в отношении веб-сайтов, которые отслеживают и передают третьим лицам историю посещений пользователей. В обновлённой политике конфиденциальности Apple говорится о
Искусственный интеллект стартапа оказался группой индийских программистов
Некоторое время назад индийский стартап Engineer.ai заявил о создании платформы на базе ИИ, способной самостоятельно создавать приложения. Но на деле он оказался командой
«
»
  • 1
  • 2

Авторизация