VK Feed icon.svg

Звоните нам: +375 (29) 3245385, +375 (29) 7505994, +375 (25) 9164238

Переключение маршрутов на MikroTik при пропадании пинга к хосту

опубликовал от 19 Май, 2014

Существует простая схема резервирования соединений с интернетом установкой разной метрики на маршруты и опрос шлюза пингами или арпами для проверки его доступности. Но иногда для соединения с провайдером используется специфичный роутер устанавливающий специфичный протокол тунелирования. Те же 4G модемы YOTA являются маршрутизаторами с USB интерфейсом не всегда совместимы с MikroTik. Для работы с ними приходится использовать промежуточные маршрутизаторы, которые будут пинговаться даже если интернет пропадёт в сети YOTA.

В этом случае создаются марки маршрутов на хосты с высоким тайм апом. Например: 8.8.8.8, 8.8.4.4, 77.88.8.8, 77.88.8.1

Создаём основной маршрут на хост 0.0.0.0/0 с марком route-gw1 и коментарием kam_gw1. Комментарий необходим так как в будущем невозможно обратится к номеру маршрута командой ввиду того, что они меняются. Приходится искать скриптом комментарий.

/ip route
add check-gateway=ping comment=kam_gw1 disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=192.168.0.1 routing-mark=route-gw1 scope=30 target-scope=10

Само собой должен быть и дополнительный маршрут на шлюз 192.168.1.1 который будет работать при отключении первого:

/ip route
add check-gateway=ping comment=kam_gw2 disabled=no distance=5 dst-address=\
0.0.0.0/0 gateway=192.168.1.1 routing-mark=route-gw1 scope=30 target-scope=10

Создадим контрольный маршрут для роутера к хосту 8.8.8.8 c марком route-1. Смысл в том что если будет пропадать/появляться пинг к хосту 8.8.8.8 c маршрутизатора NetWatch будет переключать маршрут для пользователей интернета с коментарием kam_gw1

/ip route
add check-gateway=ping comment=kontrolnij disabled=no distance=1 dst-address=\
8.8.8.8/32 gateway=192.168.0.1 routing-mark=route-1 scope=30 target-scope=10

Создадим правило маршрутизации в ip route rules для таблицы route-1 и это сделает таблицу маршрутизации для самого роутера однозначной.

Создадим проверку 8.8.8.8 в netwatch на доступность c правилами на падение и подъём хоста:

выключаем маршрут c комментарием kam_gw1 если пинг пропадает:

ip route set [find comment=kam_gw1] disable=yes 

включаем первый маршрут c комментарием kam_gw1 если пинг появляется:

ip route set [find comment=kam_gw1] disable=no

 

 

Прочитано 14400 раз Последнее изменение Вторник, 28 Март 2017 03:13
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Нур Написал Нур Апрель 30, 2019 работает на локалке, а по wifi на телефоне не работает
  • Алекс Ньюсмэйкер Написал Март 11, 2019 Стандарт Wi-Fi 5 ещё рулит несмотря на то что скоро выйдет Wi-Fi 6
  • Кардаш Александр Владимирович Написал Март 05, 2019 Видимо для того, кто купил в своё время лицензию на Висту хорошее руководство....
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по настройке маршрутизаторов MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промсвязь
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3
 rss  vk groupe

 

Нравится ли вам наш блог?


Процессоры Ryzen 3000 смогут работать с памятью DDR4-3200 без разгона
Перспективные 7-нм процессоры AMD Ryzen 3000-й серии на базе архитектуры Zen 2 смогут работать с модулями оперативной памяти DDR4-3200 прямо из коробки, без дополнительного разгона. Об этом
Обновление Windows 10 May 2019 Update заблокировано для некоторых ПК
Несколько дней назад сообщалось, что Microsoft начала развёртывание Windows 10 May 2019 Update на всех ПК в мире. И хотя полный цикл займёт время, уже известно, что у обновления есть проблемы. Если
Трамп заявил, что Huawei может стать частью торгового соглашения США и Китая
Президент США Дональд Трамп заявил, что урегулирование по Huawei может стать частью торгового соглашения между США и Китаем, несмотря на то, что оборудование телекоммуникационной фирмы признано
Facebook планирует запустить криптовалюту GlobalCoin в 2020 году
Сетевые источники сообщают о планах компании Facebook по запуску собственной криптовалюты в следующем году. Сообщается о том, что новая платёжная сеть, охватывающая 12 государств, будет развёрнута в
ИИ помогает Facebook обнаруживать и удалять до 96,8% запрещенного контента
Вчера Facebook опубликовала очередной отчёт об обеспечении соблюдения стандартов сообщества социальной сети. Компания приводит данные и показатели за временной промежуток с января по март и уделяет
AMD Ryzen 3000: 6-ядерный образец Zen 2 впечатлил результатами в SiSoftware
В базе тестового пакета SiSoftware Sandra сегодня был замечен инженерный образец 6-ядерного/12 поточного процессора AMD Zen 2 для настольной платформы AM4. Обнаруженный CPU был установлен в
Китайский клон AMD Ryzen имеет восемь ядер и частоту 3.0 ГГц
О существовании у AMD совместного предприятия с китайцами по разработке центральных процессоров для местного рынка в контексте обсуждаемых санкций США в последние дни говорится немало. Тем интереснее
Windows 10 May 2019 Update уже доступна для установки
После дополнительного месяца тестирования Microsoft всё-таки выпустила очередное обновление для Windows 10. Речь идёт, разумеется, о Windows 10 May 2019 Update. Эта версия, как ожидается, должна
«
»
  • 1
  • 2

Авторизация