fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Проброс порта на MikroTik для одного и двух провайдеров

опубликовал от 02 Август, 2016

Сколько было написано инструкций по настройке, а такой простой вещи как проброс порта в MikroTik на нашем сайте не было. Исправил этот недочёт. Рассмотрим сегодня несколько способов публикации вашего сервера в сети интернет на маршрутизаторах MikroTik. Также раскажу про публикацию сервера на двух внешних IP адресах. Есть очень простой способ это сделать не прибегая к маркировке исходящих и входящий соединений.

1. Простой проброс порта если нет статического IP

В самом простом случае проброс порта привязывется к внешнуму интерфейсу In. Interface. Для этого идём в IP/Firewall на вкладку NAT и плюсиком создаём правило:

 

 Цепочка dst-nat, входящий интерфейс ByFly, порт TCP 55555

Если порт на входе равен порту на выходе или пробросить нужно несколько портов одним правилом в поле "To port" можно ничего не писать:

 Из командной строки надо исполнить такой скрипт:

/ip firewall nat
add action=dst-nat chain=dstnat comment=torrent dst-port=55555 in-interface=\
ByFly protocol=tcp to-addresses=10.24.3.2

2. Проброс группы портов если есть статический IP

Если у провайдера выкуплен внешний статический IP правило лучше видоизменить:

Это позволит открывать изнутри сети ресурсы сервера по внешнему IP. Очень полезно для настройки на переносных устройствах которые могут подключаться к серверу как из других сетей так и по Wi-Fi. В данном случае рассмотрен проброс нескольких портов одним правилом: TCP 55555, 80, 21. 86.57.150.15 - внешний IP.

Из коммандной строки следует выполнить:

/ip firewall nat
add action=dst-nat chain=dstnat comment=probros_web_ftp_torrent dst-address=86.57.150.15\
dst-port=55555,21,80 protocol=tcp to-addresses=10.24.3.2

 3. Публикация сервера на 2-ух внешних IP

Для начала следует прописать на сервере второй IP адресс из другой подсети на сетевом интерфейсе:

 Добавляем столько адресов сколько нам нужно:

Идём в IP adresses и добавляем на сетевом интерфейсе ip 10.24.4.1/24 через который будет идти взаимодействие маршрутизатора с сервером:

Сделаем маршрут для второго провайдера с меткой route-1 для этого идём в IP/Route:

Создадим правило согласно которому сеть 10.24.4.0/24 роутится через второго провайдера:

К основному пробросу портов надо добавить проброс порта через второго провайдера:

где 86.57.150.16 IP второго провайдера.

Соответственно пробрасываем на IP 10.24.4.2:

Необходимо сделать также masquerade при обращении к 10.24.4.2 для того чтобы подключение ко второму IP WINDOWS работало:

 Настройка закончена! Теперь сервер доступен c двух внешних IP.

Прочитано 17370 раз Последнее изменение Понедельник, 17 Июль 2017 02:52
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by/about/55-kardash-aliaksandr-vladimirovich

Другие материалы с нашего сайта:

2 Комментарии

  • Игорь

    Добрый день!
    подскажите пожалуйста есть роутер Mikrotik RB 951 2n, задача состоит в том чтобы настроить 3 и 4 порт на двух независимых провайдеров, оба провайдера заходят на микротик 1 и 2 порт по DHCP, 1 провайдер шлюз 192.168.1.1 второй 192.168.100.1 как настроить так, чтобы VLAN с сетью 172.200.2.0/24 (3порт) работал через провайдера со шлюзом 192.168.1.1, а VLAN с сетью 172.200.10.0/24 (4порт) работал через провайдера со шлюзом 192.168.100.1 и вообще возможно такое сделать на данной модели. Заранее спасибо!!!

    Ответ: Конечно возможно. Роутинг полиси так называемый надо использовать...

    Игорь   Вторник, 19 Декабрь 2017 13:20
  • Vlad

    Добрый день!

    Адрес 192.168.8.1 - ето адрес чего у Вас?
    Там где Сделаем маршрут для второго провайдера с меткой ....

    Ответ: Это адрес шлюза второго провайдера ....

    Vlad   Среда, 05 Июль 2017 00:44

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Амина Написал Амина Август 25, 2019 Вот на этом ролторе написано зади логин и пароль Просто я скачала приложение и ьам…
  • Кардаш Александр Владимирович Написал Август 23, 2019 Новая моя статья с замашкой на звание хита по настройке MikroTik!
  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
 rss  vk groupe

 

Нравится ли вам наш блог?

Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промзвязь в Минске
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3


Началась сертификация устройств Wi-Fi 6 (802.11ax)
Вчера Wi-Fi Alliance официально запустил программу сертификации Wi-Fi 6, дав зелёный свет широкомасштабному принятию нового стандарта Wi-Fi (802.11ax). Как и в предыдущих программах сертификации,
Теперь официально: Microsoft точно работает над Windows Core OS
Упоминания этой ОС найдены в документах для Windows 10. Пару лет назад в Сети появились слухи о том, что Microsoft занимается разработкой новой операционной системы под названием Windows Core
AMD утверждает, что её следующие CPU Epyc будут лучше решений линейки Intel Ice Lake-SP по соотношению производительности на ватт
Эти CPU выйдут в следующем году. Анонсированные недавно серверные процессоры AMD Epyc второго поколения прямых конкурентов в стане Intel по многим параметрам попросту не имеют. Ранее AMD
Патч для Linux 5.4 улучшит ситуацию с 64-битными играми
Компания CodeWeavers, которая разрабатывает ПО CrossOver для запуска Windows-приложений под Linux, представила патч для ядра Linux 5.4. Он должен помочь улучшить работу некоторых 64-битных игр
Предложен новый вариант драйвера exFAT для Linux
В будущем релизе и актуальных бета-версиях ядра Linux 5.4 появилась поддержка драйвера для файловой системы Microsoft exFAT. Однако этот драйвер базируется на старом коде Samsung (номер версии ветки
Платформа Intel Snow Ridge предложит множество ядер с архитектурой Tremont
Ещё одним продуктом Intel, чей выпуск будет налажен по 10-нм технологии в ближайшие месяцы, станет платформа Snow Ridge для базовых станций сетей сотовой связи. Процессорный гигант полон амбиций –
Процессоры Intel Tiger Lake получат увеличенный объём кеша третьего уровня
Мобильные процессоры Tiger Lake-U с архитектурой вычислительных ядер Willow Cove и встроенной графикой Gen12 (Intel Xe) должны появиться через год-другой, но упоминания о них в документации уже
NVIDIA считает, что время чиплетов ещё не пришло
Ресурс Semiconductor Engineering в этом месяце заявил о своём существовании, опубликовав интервью с двумя представителями NVIDIA на Hot Chips 2019. Интересы компании представляли ведущий специалист
«
»
  • 1
  • 2

Авторизация