fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Скрипт DHCP-клиента для создания маркированного маршрута в MikroTik

опубликовал от 09 Ноябрь, 2018

Скрипт записан после \n . Создаёт дефолтный маршрут с указанной Routing Mark, при этом в шлюзе указывается IP-адрес.

Для создание DHCP клиента сo скриптом добавляющим маркированный маршрут в таблицу выполните в терминале следующую команду:

/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=ether2 script="{\r\
    \n    :local rmark \"WAN1\"\r\
    \n    :local count [/ip route print count-only where comment=\"WAN1\"]\r\
    \n    :if (\$bound=1) do={\r\
    \n        :if (\$count = 0) do={\r\
    \n            /ip route add gateway=\$\"gateway-address\" comment=\"WAN1\" routing-mark=\$rmark\r\
    \n        } else={\r\
    \n            :if (\$count = 1) do={\r\
    \n                :local test [/ip route find where comment=\"WAN1\"]\r\
    \n                :if ([/ip route get \$test gateway] != \$\"gateway-address\") do={\r\
    \n                    /ip route set \$test gateway=\$\"gateway-address\"\r\
    \n                }\r\
    \n            } else={\r\
    \n                :error \"Multiple routes found\"\r\
    \n            }\r\
    \n        }\r\
    \n    } else={\r\
    \n        /ip route remove [find comment=\"WAN1\"]\r\
    \n    }\r\
    \n}\r\
    \n"

Работает на версиях Router OS от 6.39rc33 и более свежих...
Можно вставить в поле скрипта DHCP клиента этот код:

{
:local rmark "WAN1"
:local count [/ip route print count-only where comment="WAN1"]
:if ($bound=1) do={
:if ($count = 0) do={
/ip route add gateway=$"gateway-address" comment="WAN1" routing-mark=$rmark
} else={
:if ($count = 1) do={
:local test [/ip route find where comment="WAN1"]
:if ([/ip route get $test gateway] != $"gateway-address") do={
/ip route set $test gateway=$"gateway-address"
}
} else={
:error "Multiple routes found"
}
}
} else={
/ip route remove [find comment="WAN1"]
}
}

Основано на официальном wiki

Обучение: Как настроить MikroTik с нуля?

Научитесь работать с оборудованием MikroTik и RouterOS по видеокурсу «Настройка оборудования MikroTik». Проходите уроки в комфортном темпе и когда удобно – все материалы остаются у вас бессрочно. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект. Пройдя курс, вы сможете настроить маршрутизатор MikroTik с нуля, даже если у вас не будет в наличии реального оборудования. Начало курса можно посмотреть бесплатно, оставив заявку здесь.

Прочитано 3654 раз Последнее изменение Пятница, 09 Ноябрь 2018 17:12
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by/about/55-kardash-aliaksandr-vladimirovich

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Амина Написал Амина Август 25, 2019 Вот на этом ролторе написано зади логин и пароль Просто я скачала приложение и ьам…
  • Кардаш Александр Владимирович Написал Август 23, 2019 Новая моя статья с замашкой на звание хита по настройке MikroTik!
  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
 rss  vk groupe

 

Нравится ли вам наш блог?

Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промзвязь в Минске
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3


Началась сертификация устройств Wi-Fi 6 (802.11ax)
Вчера Wi-Fi Alliance официально запустил программу сертификации Wi-Fi 6, дав зелёный свет широкомасштабному принятию нового стандарта Wi-Fi (802.11ax). Как и в предыдущих программах сертификации,
Теперь официально: Microsoft точно работает над Windows Core OS
Упоминания этой ОС найдены в документах для Windows 10. Пару лет назад в Сети появились слухи о том, что Microsoft занимается разработкой новой операционной системы под названием Windows Core
AMD утверждает, что её следующие CPU Epyc будут лучше решений линейки Intel Ice Lake-SP по соотношению производительности на ватт
Эти CPU выйдут в следующем году. Анонсированные недавно серверные процессоры AMD Epyc второго поколения прямых конкурентов в стане Intel по многим параметрам попросту не имеют. Ранее AMD
Патч для Linux 5.4 улучшит ситуацию с 64-битными играми
Компания CodeWeavers, которая разрабатывает ПО CrossOver для запуска Windows-приложений под Linux, представила патч для ядра Linux 5.4. Он должен помочь улучшить работу некоторых 64-битных игр
Предложен новый вариант драйвера exFAT для Linux
В будущем релизе и актуальных бета-версиях ядра Linux 5.4 появилась поддержка драйвера для файловой системы Microsoft exFAT. Однако этот драйвер базируется на старом коде Samsung (номер версии ветки
Платформа Intel Snow Ridge предложит множество ядер с архитектурой Tremont
Ещё одним продуктом Intel, чей выпуск будет налажен по 10-нм технологии в ближайшие месяцы, станет платформа Snow Ridge для базовых станций сетей сотовой связи. Процессорный гигант полон амбиций –
Процессоры Intel Tiger Lake получат увеличенный объём кеша третьего уровня
Мобильные процессоры Tiger Lake-U с архитектурой вычислительных ядер Willow Cove и встроенной графикой Gen12 (Intel Xe) должны появиться через год-другой, но упоминания о них в документации уже
NVIDIA считает, что время чиплетов ещё не пришло
Ресурс Semiconductor Engineering в этом месяце заявил о своём существовании, опубликовав интервью с двумя представителями NVIDIA на Hot Chips 2019. Интересы компании представляли ведущий специалист
«
»
  • 1
  • 2

Авторизация