VK Feed icon.svg

Звоните нам: +375 (29) 3245385, +375 (29) 7505994, +375 (25) 9164238

Скрипт DHCP-клиента для создания маркированного маршрута в MikroTik

опубликовал от 09 Ноябрь, 2018

Скрипт записан после \n . Создаёт дефолтный маршрут с указанной Routing Mark, при этом в шлюзе указывается IP-адрес.

Для создание DHCP клиента сo скриптом добавляющим маркированный маршрут в таблицу выполните в терминале следующую команду:

/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=ether2 script="{\r\
    \n    :local rmark \"WAN1\"\r\
    \n    :local count [/ip route print count-only where comment=\"WAN1\"]\r\
    \n    :if (\$bound=1) do={\r\
    \n        :if (\$count = 0) do={\r\
    \n            /ip route add gateway=\$\"gateway-address\" comment=\"WAN1\" routing-mark=\$rmark\r\
    \n        } else={\r\
    \n            :if (\$count = 1) do={\r\
    \n                :local test [/ip route find where comment=\"WAN1\"]\r\
    \n                :if ([/ip route get \$test gateway] != \$\"gateway-address\") do={\r\
    \n                    /ip route set \$test gateway=\$\"gateway-address\"\r\
    \n                }\r\
    \n            } else={\r\
    \n                :error \"Multiple routes found\"\r\
    \n            }\r\
    \n        }\r\
    \n    } else={\r\
    \n        /ip route remove [find comment=\"WAN1\"]\r\
    \n    }\r\
    \n}\r\
    \n"

Работает на версиях Router OS от 6.39rc33 и более свежих...
Можно вставить в поле скрипта DHCP клиента этот код:

{
:local rmark "WAN1"
:local count [/ip route print count-only where comment="WAN1"]
:if ($bound=1) do={
:if ($count = 0) do={
/ip route add gateway=$"gateway-address" comment="WAN1" routing-mark=$rmark
} else={
:if ($count = 1) do={
:local test [/ip route find where comment="WAN1"]
:if ([/ip route get $test gateway] != $"gateway-address") do={
/ip route set $test gateway=$"gateway-address"
}
} else={
:error "Multiple routes found"
}
}
} else={
/ip route remove [find comment="WAN1"]
}
}

Основано на официальном wiki

Обучение: Как настроить MikroTik с нуля?

Научитесь работать с оборудованием MikroTik и RouterOS по видеокурсу «Настройка оборудования MikroTik». Проходите уроки в комфортном темпе и когда удобно – все материалы остаются у вас бессрочно. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект. Пройдя курс, вы сможете настроить маршрутизатор MikroTik с нуля, даже если у вас не будет в наличии реального оборудования. Начало курса можно посмотреть бесплатно, оставив заявку здесь.

Прочитано 2345 раз Последнее изменение Пятница, 09 Ноябрь 2018 17:12
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Последние комментарии:

  • Vlad Написал Vlad Июль 05, 2017 Добрый день! Адрес 192.168.8.1 - ето адрес чего у Вас? Там где Сделаем маршрут для…
  • Виталий Написал Виталий Май 17, 2016 Не подскажите, возможно ли сделать данную операцию в случае использования двух PPPoE интерфейсов (динамическая адресация),…
  • Максим Написал Максим Ноябрь 03, 2013 Все работает отлично, по данной схеме мне помог настроить Александр, связывался с ним по skype,…
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по настройке маршрутизаторов MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промсвязь
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3
 rss  vk groupe

 

Нравится ли вам наш блог?


Windows 7 начала напоминать о скором прекращении поддержки
Компания Microsoft планирует прекращение поддержки Windows 7 на 14 января 2020 года. При этом в мире есть сотни миллионов пользователей ПК, которые до сих пор не обновились до более современной
Facebook хранила сотни миллионов паролей пользователей в обычных текстовых файлах
Способ хранения паролей — базовый вопрос безопасности. Тем не менее, время от времени достоянием общественности становятся скандалы, связанные с тем, что те или иные большие или малые компании
В velcom появился LTE: вот как он работает
Сегодня телеком-оператор velcom начал предоставлять услуги в сети LTE. Мы вышли на улицы Минска, чтобы проверить скорость подключения к интернету в сети четвертого поколения, предоставляемой
Intel на GDC 2019: новые мобильные CPU и панель управления графикой
Корпорация Intel в ходе конференции разработчиков видеоигр GDC 2019 представила новую панель управления интегрированной графикой, а также анонсировала мобильные процессоры Core 9-го поколения. Свежие
В DirectX 12 добавлена поддержка Variable Rate Shading
Одной из главных задач игростроя и программирования в целом является оптимизация без существенной потери качества. Потому в своё время появилась куча кодеков для аудио и видео, которые обеспечивали
Samsung анонсировала скоростную память HBM2E
Samsung Electronics продолжает улучшать скоростные показатели оперативной памяти типа HBM (High Bandwidth Memory). В ходе GPU Technology Conference 2019 южнокорейский гигант представил первые
NVIDIA будет сохранять бдительность в связи в возвращением Intel в сегмент дискретной графики
Всё прогрессивное человечество сейчас смакует новость о том, что Google для своей "облачной" игровой платформы Stadia выбрала не только центральные процессоры AMD, но и графические процессоры этой
AMD хочет размещать чипы памяти прямо над кристаллом процессора
Недавно на мероприятии, посвящённом высокопроизводительным вычислениям, глава отдела устройств для центров обработки данных (Datacenter Group) компании AMD Форрест Норрод (Forrest Norrod) поделился
«
»
  • 1
  • 2

Авторизация