fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Скрипт переключения каналов интернета и E-mail оповещения на MikroTik

опубликовал от 30 Июль, 2019

Доброго времени суток читателям моего блога. Сегодня выкладываю вариант скрипта для MikroTik на проверку соединения с интернетом WAN1 и отправку e-mail о его падении. Скрипт писал не я, а взят он с рабочего роутера, на котором всё шикарно выполнялось.

C периодичностью 30 секунд надо выполнять скрипт: Назовём его: TestChanel и добавим System/Script

 

:global to "Этот адрес электронной почты защищен от спам-ботов. У вас должен быть включен JavaScript для просмотра."
:global HostPing 77.88.8.8

:global OldTestWan1
:global OldTestWan2

 

:global TestWan1 [([:ping $HostPing count=3 routing-table=wan1_route] > 0)]

:if (($TestWan1 = false) and ($TestWan1 != $OldTestWan1)) do={
/ip route disable [find comment="wan1"]
/log warning "WAN1 is Down"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN1 connection is lost."
} on-error={/log warning "No send Email"}
}

:if (($TestWan1 = true) and ($TestWan1 != $OldTestWan1)) do={
/ip route enable [find comment="wan1"]
/log warning "WAN1 is UP"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN1 connection restored."
} on-error={/log warning "No send Email"}
}

:global TestWan2 [([:ping $HostPing count=3 routing-table=wan2_route] > 0)]

:if (($TestWan2 = false) and ($TestWan2 != $OldTestWan2)) do={
/ip route disable [find comment="wan2"]
/log warning "WAN2 is Down"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN2 connection is lost."
} on-error={/log warning "No send Email"}
}

:if (($TestWan2 = true) and ($TestWan2 != $OldTestWan2)) do={
/ip route enable [find comment="wan2"]
/log warning "WAN2 is UP"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN2 connection restored."
} on-error={/log warning "No send Email"}
}

:set OldTestWan1 $TestWan1
:set OldTestWan2 $TestWan2

 

В IP/Route надо сделать  комментарии для основных маршрутов провайдера 1  - wan1, провайдера 2 - wan2 

Также надо добавить маршруты к 0.0.0.0/0 для WAN1 и WAN2 с марками wan1_route и wan2_route. 

Добавить в IP/Route/Rule правила маршрутизации:

1 route 

В шедуллер добавить правило:

/system script run TestChanel

 

P.S Возможно нужно ещё заполнить в Tools/Email настройки вашего SMTP:

1

 

Прочитано 720 раз Последнее изменение Среда, 07 Август 2019 15:25
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by/about/55-kardash-aliaksandr-vladimirovich

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Амина Написал Амина Август 25, 2019 Вот на этом ролторе написано зади логин и пароль Просто я скачала приложение и ьам…
  • Кардаш Александр Владимирович Написал Август 23, 2019 Новая моя статья с замашкой на звание хита по настройке MikroTik!
  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
Блондинка и программист
Две версии одного анекдота Версия программистаПрограммист рассказывает своим друзьям, таким же, как он:- Вчера в ночном клубе я познакомился с клевой блондинкой!Друзья:- Ух ты!- Потом я пригласил ее к себе, мы с ней выпили, я начал ее ласкать.- Здорово!- Тут она мне говорит: "Раздень меня!"-
Анегдот дня
Что делает сисадмин, просыпаясь после дикой пьянки?— Тестирует память…
Много общего с интернетом!
— Между моей девушкой и Интернетом есть много общего.— Ага, пользователей много.
Анегдот дня
Хотите превратить свой Core i9 в Core i3? Поставьте себе на машину антивирус Касперского :)  
Анегдоты дня
Завещание Билла Гейтса ежемесячно автоматически обновляется. У Билла Гейтса родилась дочь. Назвали «Новая папка».
Сколько программистов нужно чтобы заменить лампочку?
  Сколько программистов нужно чтобы заменить лампочку? Ни одного. Перегоревшая лампочка это аппаратная проблема и програмисты их не решают.
Вредоносная программа
Встретились два программиста. Один говорит:— В моей жизни появилась вредоносная программа!— Какая вредоносная программа?— Жена…
Анегдот дня
- Чем отличается программист от политика? - Программисту платят деньги за работающие программы.
Анегдот дня
Потомственный системный администратор Сергей. Очное и заочное (по IP-адресу) лечение компьютеров. Гадание по портам (COM, LPT, USB).  
Анегдот дня
— Вы уволены!— За что?!— За ошибки в ваших программках.— Не согласен, ошибки есть даже у Билла Гейтса, посмотрите, столько их у него в Офисе!— Не надо валить все на Билла Гейтса. Вы пишите свои программки не для его офиса, а для нашего оперного театра!  
С днём рождения Linux
  Доктор, я страдаю от галлюцинаций. Или проще, у меня глюки. - А какая у Вас операционная система?- Windows.- Могу посоветовать перейти на Linux. Но предупреждаю, глюки должны исчезнуть, но получите геморрой.
Компьютеризмы
И сисадмины скачивают порнуху. Каждая мышка должна знать свой коврик. Если Windows больше нечего сказать, он посылает всех на три клавиши. И лицензионный Windows глючит. Троянский конь всегда найдет ахиллесову пяту вашего компьютера. Хороший сисадмин никогда не перепутает дисковый Raid от Raid
Анегдоты дня
Идёт сисадмин, несёт бутылку вина. Его спрашивают: — Откуда? Он: — Да в конторе одной починил принтер. факс, ещё кое—что… — «Кое—что» — это ты говорить не хочешь или сам не знаешь, что починил?   Если бы сисадмины работали в МЧС: — Приезжайте, здесь желтая двенадцатиэтажка
Анегдот дня
— Чем шизофреник отличается от сисадмина?— Первый общается с кофеварками, второй — с чайниками.  
Разгон процессора
  В жизни есть только три вещи, от которых некуда деться - это смерть,налоги и желание иметь более быстрый процессор!   Встречаются русский, американец и японец, ну и начали спорить у кого технологиикруче. Американец и говорит:- Вот у нас в Америке берем болванку, бац по болванке
Анегдоты дня
Любителям приводить в пример Билла Гейтса как успешного человека, бросившего учебу, стоит помнить, что он бросил Гарвард, а не задрищенское ПТУ. — Исаак, ты слышал, что Тарантино снял «Убить Билла», когда пытался установить у себя Windows XP?— Да, Абраша, а «Убить Билла 2» — когда, наконец, смог
Анегдоты дня
Разговаривают два сисадмина: — Чертова работа… Позавчера ушел в 3 часа ночи, вчера ушел в час ночи… — Что, вчера отпросился?    Не ругайте Господа нашего. Представьте сеть, в которой 6 миллиарда юзеров. А каково быть там сисадмином?    На следующий день после
«
»
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • 107
  • 108
  • 109
  • 110
  • 111
  • 112
 rss  vk groupe

 

Нравится ли вам наш блог?

Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промзвязь в Минске
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3


SK Hynix переводит выпуск памяти типа DDR4 на новую ступень литографии
Южнокорейская компания SK Hynix сообщила о покорении нового технологического рубежа. Ею освоен выпуск 16-гигабитных микросхем DDR4 с использованием технологии класса «1z нм», но без применения
Роботизированные ударная установка и контрабас Yamaha: живые выступления можно будет слушать в записи
Казалось бы, как можно слушать живые выступления музыкантов в записи? Нет ли в этом нонсенса? Нет, — утверждает Yamaha. Известнейший во всём мире бренд на рынке музыкальных инструментов представил
AMD: мы выигрываем у Intel на 400% за доллар благодаря процессорам EPYC на базе Zen 2
AMD недавно выпустила 2-е поколение процессоров EPYC на базе Zen 2. Многочисленные тесты подтвердили преимущество чипов AMD над соперниками из стана серверных чипов Intel. Пытаясь противостоять всё
Услуги по трёхмерной компоновке TSMC сделает своим самым динамично растущим бизнесом
Компания TSMC уже начала готовить почву для эволюционных изменений в полупроводниковой отрасли, которая вынуждена ради поддержания действия так называемого «закона Мура» повышать плотность размещения
ИИ используется как дешифратор древних надписей
За последние несколько лет использование нейросетей и искусственного интеллекта увеличилось в разы. Так, с помощью нейросетей ищут и изучают экзопланеты, подменяют знаменитостей и даже грабят банки.
MRAM увеличивает шансы стать следующей массовой энергонезависимой памятью
Мало кто обратил внимание на новость прошедшего лета о поставках нового производственного оборудования компании Applied Materials. А новость эта знаковая. В ней сообщалось, что Applied Materials
Эксперты считают, что Intel не суждено догнать TSMC в сфере литографии
На этой неделе компания TSMC отчиталась о результатах деятельности в третьем квартале, ещё раз напомнив о своём прогрессе в сфере освоения новых ступеней литографии. Массовое производство по второму
Первый пошёл: Alphabet Wing обслужила первый заказ по доставке дронами
Как сообщает информагентство CNBC со ссылкой на компанию Alphabet, в минувшую пятницу служба Wing компании совместно со службой доставки FedEx осуществила первую коммерческую доставку товаров
«
»
  • 1
  • 2

Авторизация