VK Feed icon.svg

Звоните нам: +375 (29) 3245385, +375 (29) 7505994, +375 (25) 9164238

Переключение маршрутов на MikroTik при пропадании пинга к хосту

опубликовал от 19 Май, 2014

Существует простая схема резервирования соединений с интернетом установкой разной метрики на маршруты и опрос шлюза пингами или арпами для проверки его доступности. Но иногда для соединения с провайдером используется специфичный роутер устанавливающий специфичный протокол тунелирования. Те же 4G модемы YOTA являются маршрутизаторами с USB интерфейсом не всегда совместимы с MikroTik. Для работы с ними приходится использовать промежуточные маршрутизаторы, которые будут пинговаться даже если интернет пропадёт в сети YOTA.

В этом случае создаются марки маршрутов на хосты с высоким тайм апом. Например: 8.8.8.8, 8.8.4.4, 77.88.8.8, 77.88.8.1

Создаём основной маршрут на хост 0.0.0.0/0 с марком route-gw1 и коментарием kam_gw1. Комментарий необходим так как в будущем невозможно обратится к номеру маршрута командой ввиду того, что они меняются. Приходится искать скриптом комментарий.

/ip route
add check-gateway=ping comment=kam_gw1 disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=192.168.0.1 routing-mark=route-gw1 scope=30 target-scope=10

Само собой должен быть и дополнительный маршрут на шлюз 192.168.1.1 который будет работать при отключении первого:

/ip route
add check-gateway=ping comment=kam_gw2 disabled=no distance=5 dst-address=\
0.0.0.0/0 gateway=192.168.1.1 routing-mark=route-gw1 scope=30 target-scope=10

Создадим контрольный маршрут для роутера к хосту 8.8.8.8 c марком route-1. Смысл в том что если будет пропадать/появляться пинг к хосту 8.8.8.8 c маршрутизатора NetWatch будет переключать маршрут для пользователей интернета с коментарием kam_gw1

/ip route
add check-gateway=ping comment=kontrolnij disabled=no distance=1 dst-address=\
8.8.8.8/32 gateway=192.168.0.1 routing-mark=route-1 scope=30 target-scope=10

Создадим правило маршрутизации в ip route rules для таблицы route-1 и это сделает таблицу маршрутизации для самого роутера однозначной.

Создадим проверку 8.8.8.8 в netwatch на доступность c правилами на падение и подъём хоста:

выключаем маршрут c комментарием kam_gw1 если пинг пропадает:

ip route set [find comment=kam_gw1] disable=yes 

включаем первый маршрут c комментарием kam_gw1 если пинг появляется:

ip route set [find comment=kam_gw1] disable=no

 

 

Прочитано 13590 раз Последнее изменение Вторник, 28 Март 2017 03:13
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Последние комментарии:

  • Vlad Написал Vlad Июль 05, 2017 Добрый день! Адрес 192.168.8.1 - ето адрес чего у Вас? Там где Сделаем маршрут для…
  • Виталий Написал Виталий Май 17, 2016 Не подскажите, возможно ли сделать данную операцию в случае использования двух PPPoE интерфейсов (динамическая адресация),…
  • Максим Написал Максим Ноябрь 03, 2013 Все работает отлично, по данной схеме мне помог настроить Александр, связывался с ним по skype,…
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по настройке маршрутизаторов MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промсвязь
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3
 rss  vk groupe

 

Нравится ли вам наш блог?


Браузер электромобилей Tesla переведут на Chromium
Браузер, который используется в электромобилях Tesla, не может похвастаться стабильностью. Потому вполне логично, что его нужно обновить. Сооснователь компании Илон Маск уже сообщил в Twitter, что
Процессоры AMD набирают популярность в европейской рознице
Как сообщает нидерландское издание Tweakers, в странах Бенилюкса (политический и экономический союз Бельгии, Нидерландов и Люксембурга) продажи отдельных процессоров AMD Ryzen показывают стабильный
Подробности обо всех моделях встроенных графических процессоров Intel 11-го поколения
Новостей о графических процессорах Intel много не бывает. Вслед за подробностями об архитектуре и производительности встроенной графики Intel 11-го поколения в нашем распоряжении появилась информация
Встроенная графика Intel 11-го поколения оказалась быстрее AMD Vega 10 в Ashes of the Singularity
Вслед за подробным описанием архитектуры будущей встроенной графики Intel 11-го поколения (Gen11) в Сети появилась новая информация о её производительности. Известный источник утечек с псевдонимом
Устройства PCIe SSD займут половину рынка твердотельных накопителей в 2019 году
Уже к концу текущего года твердотельные накопители (SSD) с интерфейсом PCIe могут сравняться по объёму поставок с флеш-решениями, использующими интерфейс SATA.  Снижающиеся цены на чипы
Windows 7 начала напоминать о скором прекращении поддержки
Компания Microsoft планирует прекращение поддержки Windows 7 на 14 января 2020 года. При этом в мире есть сотни миллионов пользователей ПК, которые до сих пор не обновились до более современной
Facebook хранила сотни миллионов паролей пользователей в обычных текстовых файлах
Способ хранения паролей — базовый вопрос безопасности. Тем не менее, время от времени достоянием общественности становятся скандалы, связанные с тем, что те или иные большие или малые компании
В velcom появился LTE: вот как он работает
Сегодня телеком-оператор velcom начал предоставлять услуги в сети LTE. Мы вышли на улицы Минска, чтобы проверить скорость подключения к интернету в сети четвертого поколения, предоставляемой
«
»
  • 1
  • 2

Авторизация