fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Настройка MikroTik PCC: Обьединение двух провайдеров и резервирование.

опубликовал от 02 Июнь, 2013

Существуют задачи для которых необходима большая пропускная способность канала интернета и высокая его достуность. Какой бы у вас не был хороший провайдер он не резервирует канал к своим пользователям. Практика показывает что раз в месяц интернет пропасть может у любого абонента подключённого как по ADSL так и Ethernet. Также провайдер не предоставляет больших скоростей чем те которые есть в его официальных тарифных планах. Выход может быть в подключении второго резервного провайдера. Что можно сделать чтобы всегда оставаться на связи и использовать на максимум ваш резервный канал. Как в несколько раз быстрее загружать файлы с торрентов и при этом добиться корректной работы приложений плохо работающих при балансировке пакетов? Как опубликовать сервисы вашего сервера в интернете при использовании обьединённых каналов? Тема этой статьи обьединение каналов на Mikrotik.

Для начала создадим два PPPoE соединения с провайдером назвав их pppoe-byfly1и pppoe-byfly2. Для этого выполним в терминале:

/interface pppoe-client
add disabled=no interface=ether1-gateway name=pppoe-byfly1 password=11111111 use-peer-dns=yes user=Этот адрес электронной почты защищен от спам-ботов. У вас должен быть включен JavaScript для просмотра.
add disabled=no interface=ether1-gateway name=pppoe-byfly2 password=22222222 user=Этот адрес электронной почты защищен от спам-ботов. У вас должен быть включен JavaScript для просмотра.

Проследите чтобы маршрутизатор не взял основной шлюз ни с одного из этих соединений, а также с DHCP клиента на первом порту. Всеми маршрутами будем манипулировать вручную.

Будем рассматривать ситуацию в которой мы не меняем ip адреса установленные изготовителем маршрутизатора (192.168.88.1/24). Интерфейс который смотрит на пользователей в большинстве маршрутизаторов Mikrotik умолчанию bridge-local.  Для того чтобы прописать ip в роутер тем кто всё же удалил его выполните в консоли это:

/ip address
add address=192.168.88.1/24 broadcast=192.168.0.255 comment="LAN" disabled=no interface=bridge-local network=192.168.88.0

Не забывает сделать NAT для соединений с интернетом:

/ip firewall nat
add action=masquerade chain=srcnat comment="nat1" disabled=no out-interface=pppoe-byfly1
add action=masquerade chain=srcnat comment="nat2" disabled=no out-interface=pppoe-byfly2

Приступим к маркировке соединений. Пользователи которым будет производится склейка канала будут находится в диапазоне ip 192.168.88.0/25. Диапазон 192.168.88.128/25 будет выходить в интернет только через соединение pppoe-byfly2 и для него будет доступно только резервирование:

/ip firewall mangle
add action=mark-connection chain=prerouting comment="mark-out-byfly1-connection" disabled=no dst-address-type=!local new-connection-mark=pppoe1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 src-address=192.168.88.0/25
add action=mark-connection chain=prerouting comment="mark-out-byfy2-connection" disabled=no dst-address-type=!local new-connection-mark=pppoe2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1 src-address=192.168.88.0/25

Отмаркируем маршруты:

/ip firewall mangle

add action=mark-routing chain=prerouting comment="mark-out-routing1" connection-mark=pppoe1_conn disabled=no new-routing-mark=to_pppoe1 passthrough=yes src-address=192.168.88.0/25
add action=mark-routing chain=prerouting comment="mark-out-routing2" connection-mark=pppoe2_conn disabled=no new-routing-mark=to_pppoe2 passthrough=yes src-address=192.168.88.0/25

Пропишем основной маршрут для роутера и маркированный метками to_pppoe1, to_pppoe2 для пользователей в сети 192.168.88.0/25

/ip route
add check-gateway=arp comment="for-router-and-192.168.88.128/25" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-byfly2
add check-gateway=arp comment="for-192.168.88.0/25" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-byfly2 routing-mark=to_pppoe2
add check-gateway=arp comment="for-192.168.88.0/25" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-byfly1 routing-mark=to_pppoe1

Обеспечим взаимное резервирование каналов чтобы при падении одного из них пользователи не остались без интернета:

/ip route

add check-gateway=arp comment="rezerv-for-192.168.88.0/25 " disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-byfly2 routing-mark=to_pppoe1
add check-gateway=arp comment="rezerv-for-192.168.88.0/25" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-byfly1 routing-mark=to_pppoe2
add check-gateway=arp comment="rezerv-for-router-and-192.168.88.128/25" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-byfly1

 У данной схемы баллансировки есть недостатки:

 Она не позволяет публиковать сервисы серверов в интернете поэтому их следует разместить в диапазоне 192.168.88.128/25 и пробросить порты следующими командами в терминале:

/ip firewall nat
add action=dst-nat chain=dstnat comment=FTP dst-port=21 in-interface=pppoe-byfly2 protocol=tcp to-addresses=192.168.88.254 to-ports=21
add action=dst-nat chain=dstnat comment=HTTP dst-port=80 in-interface=pppoe-byfly2 protocol=tcp to-addresses=192.168.88.254 to-ports=80

где 192.168.88.254 ip сервера а 80 и 21 порты tcp на которых работают сервисы.

Эту схему балансировки не корректно поддерживают некоторые сайты поэтому для 80 и 443 порта рекомендуем её не использовать. Для того чтобы весь http и https трафик не метался между соединениями добавим в mangle перед всеми правилами маркировку маршрутов которая повернёт его полностью на второе соединение с интернетом:

/ip firewall mangle
add action=mark-routing chain=prerouting comment="443 80 mark routing" \
 dst-port=443,80 new-routing-mark=to_pppoe2 passthrough=no protocol=tcp

Можно как альтернативу попробовать также балансировать трафик на 80 и 443 порт выбрав per-connection-classifier равным src-address. Добавлять в mangle эти правила следует перед всеми маркировками маршрутов:

/ip firewall mangle

add action=mark-connection chain=prerouting comment=mark-out-byfy2-connection-on-80-443 dst-address-type=!local dst-port=80,443 new-connection-mark=pppoe2_conn per-connection-classifier=src-address:2/1 protocol=tcp src-address=192.168.88.0/25
add action=mark-connection chain=prerouting comment=mark-out-byfly1-connection-on-80-443 dst-address-type=!local dst-port=80,443 new-connection-mark=pppoe1_conn per-connection-classifier=src-address:2/1 protocol=tcp src-address=192.168.88.0/25

В данном случае вы получите менее равномерную баллансировку каналов, зато открытие сайтов будет происходить лучше.

Ещё вы можете у нас заказать платную настройку маршрутизатора.

Прочитано 66570 раз Последнее изменение Понедельник, 16 Июль 2018 00:01
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by/about/55-kardash-aliaksandr-vladimirovich

Другие материалы с нашего сайта:

8 Комментарии

  • evgen

    Тут:
    /ip address add address=192.168.88.1/24 broadcast=192.168.0.255 comment="LAN" disabled=no interface=bridge-local network=192.168.88.0

    broadcast=192.168.0.255 - лишнее?

    evgen   Вторник, 07 Февраль 2017 11:44
  • МИХАИЛ

    стоит два моста, на удалении от города 10 км. на каждый мост приходится по 50 Мбит, и соответственно стоит 2 микротика 750, PPPoE соединение. Возможно ли эти 2 моста соеденить в 1 микротик, и чтоб на выходе LAN получить 100 Мбит. Чтоб как то это все аккуратно балансировало? Чтоб 2 PPPoE соеденения были в одном микротике. А в лучшем варианте 3! 3 wan -2 lan.

    Ответ: Можно на основе этого сделать https://netflow.by/blog/item/139-kak-ispolzavat-dva-kanala-interneta-ot-odnogo-ethernet-provaidetra

    МИХАИЛ   Четверг, 10 Март 2016 06:20
  • Андрей

    Доброго дня! Вот вопросик:
    есть 2 провайдера
    ADSL.BY
    Atlant Telecom
    пришли они в микротик. работают себе, но как допустим из 20-ти пользователей, 5-и дать атлант а 15-ти adsl.by Ну и что бы при отказе одного, всех на работающий, а потом обратно.

    Ответ: Отмаркируйте маршруты пользователей 2-я routing mark в mangle. Для каждого routing mark создайте свою таблицу маршрутизации с двумя маршрутами. Метрики на маршрутах должны быть разными...

    Андрей   Среда, 18 Ноябрь 2015 10:31
  • Владимир

    работает нормально единственная балансировка которая более менее работает у меня ! у меня 1 провайдер билайн L2TP статика для физ лиц 2 провайдер ростелеком PPPOE адрес автоматом без шлюза ! хотелось бы у вас увидеть такую схему перерыл весь интернет единственно только ваш пример более менее работает

    Владимир   Понедельник, 20 Январь 2014 12:05
  • Юрий

    Вопрос, если:
    " мы не меняем ip адреса установленные изготовителем маршрутизатора (192.168.88.1/24)"
    При этом делаем правила для тех кто в общие правила не попал:
    "for-router-and-192.168.88.128/25" и "rezerv-for-router-and-192.168.88.128/25"
    Каким образом мы роутер исключаем? Роутер же у нас остался внизу, где пользователи в и-нет ходят? Или я что-то не доглядел?

    Юрий   Пятница, 17 Январь 2014 15:53
  • Mihail

    Хотелось бы увидеть пример настройки подключения к МТИС эзернет по L2TP . Мтис что то намутил. Просто классическое соединение происходит, но рвется ровно через минуту Даже если проманипулировать маршрутами по умолчанию Все равно рвет через минуту. АСУС за 20 зеленых соединяется и не рвет связь Мистика прямо какая то...

    Ответ: Такой проблемы пока не встречал. Сейчас могу посоветовать только поменять прошивку на Mikrotik. Попробуйте или обновиться или наоборот вернуться на пятую версию Router OS

    Mihail   Четверг, 05 Декабрь 2013 16:47
  • Андрей

    Можно ли ссумировать несколько PPPoE подключений к одному провайдеру, у всех один шлюз?

    Ответ: Да, можно! Ничего для этого специально настраивать не надо...

    Андрей   Четверг, 05 Декабрь 2013 00:24
  • Максим

    Все работает отлично, по данной схеме мне помог настроить Александр, связывался с ним по skype, указному в контактах на этом сайте. Рекомендую его как квалифицированного специалиста, он быстро разобрался в проблеме и все настроил, и мне стало понятно в чем моя ошибка.

    Максим   Воскресенье, 03 Ноябрь 2013 18:49

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Амина Написал Амина Август 25, 2019 Вот на этом ролторе написано зади логин и пароль Просто я скачала приложение и ьам…
  • Кардаш Александр Владимирович Написал Август 23, 2019 Новая моя статья с замашкой на звание хита по настройке MikroTik!
  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
 rss  vk groupe

 

Нравится ли вам наш блог?

Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промзвязь в Минске
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3


64-ядерный AMD Epyc 7742 — первый в мире процессор, позволяющий кодировать видео 8К по стандарту HEVC в реальном времени
Разработанное Beamr Imaging ПО использовало все 64 ядра CPU в процессе кодирования. Процессоры AMD Epyc нового поколения, и в особенности 64-ядерный Epyc 7742, собрали уже немало восторженных
Windows 10 теперь показывает заряд смартфона и синхронизирует обои
Компания Microsoft ещё раз обновила приложение Your Phone для Windows 10. Теперь эта программа показывает уровень заряда батареи подключённого смартфона, а также синхронизирует обои с мобильным
В ЕС хотят разработать единую цифровую валюту и заблокировать криптовалюту Facebook Libra
Франция выступила с предложением создать европейскую общедоступную цифровую валюту. Об этом заявил министр финансов республики Брюно ле Мэр, передает Reuters. Он не привел никаких деталей, какой
В день запуска одновременное количество игроков в Borderlands 3 вдвое превысило показатель Borderlands 2
Глава Gearbox Software Рэнди Питчфорд похвастался успехами запуска Borderlands 3. Он заявил, что при запуске количество одновременных игроков шутера на PC вдвое превысило показатель предыдущей части.
Новый безвентиляторный неттоп Minix использует платформу Intel Gemini Lake
К выпуску готовится компьютер небольшого форм-фактора Minix NEO G41V-4, образцы которого демонстрировались на недавней выставке электроники IFA 2019 в Берлине (Германия). Неттоп построен на
В Adobe Premiere появится функция автоматической подгонки ширины и высоты видео под разные форматы
Чтобы подогнать видео под разные варианты соотношения сторон, придётся потрудиться. Простое изменение настроек проекта с широкоформатного режима на квадратный не даст нужного результата: поэтому
Франция будет блокировать разработку Facebook Libra
Разрабатываемый Facebook стейблкоин Libra сталкивается с новым препятствием — на этот раз со стороны французского правительства. Министр экономики и финансов страны Бруно Ле Мэр заявил, что Libra
Инструменты для блокировки Telegram проверят в Тюмени
Крупные операторы связи РФ планируют в этом месяце протестировать инструменты для блокировки Telegram. Первый этап — блокирование мессенджера на региональном уровне, а конкретнее — в Тюмени.
«
»
  • 1
  • 2

Авторизация