fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Переключение маршрутов на MikroTik при пропадании пинга к хосту

опубликовал от 19 Май, 2014

Существует простая схема резервирования соединений с интернетом установкой разной метрики на маршруты и опрос шлюза пингами или арпами для проверки его доступности. Но иногда для соединения с провайдером используется специфичный роутер устанавливающий специфичный протокол тунелирования. Те же 4G модемы YOTA являются маршрутизаторами с USB интерфейсом не всегда совместимы с MikroTik. Для работы с ними приходится использовать промежуточные маршрутизаторы, которые будут пинговаться даже если интернет пропадёт в сети YOTA.

В этом случае создаются марки маршрутов на хосты с высоким тайм апом. Например: 8.8.8.8, 8.8.4.4, 77.88.8.8, 77.88.8.1

Создаём основной маршрут на хост 0.0.0.0/0 с марком route-gw1 и коментарием kam_gw1. Комментарий необходим так как в будущем невозможно обратится к номеру маршрута командой ввиду того, что они меняются. Приходится искать скриптом комментарий.

/ip route
add check-gateway=ping comment=kam_gw1 disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=192.168.0.1 routing-mark=route-gw1 scope=30 target-scope=10

Само собой должен быть и дополнительный маршрут на шлюз 192.168.1.1 который будет работать при отключении первого:

/ip route
add check-gateway=ping comment=kam_gw2 disabled=no distance=5 dst-address=\
0.0.0.0/0 gateway=192.168.1.1 routing-mark=route-gw1 scope=30 target-scope=10

Создадим контрольный маршрут для роутера к хосту 8.8.8.8 c марком route-1. Смысл в том что если будет пропадать/появляться пинг к хосту 8.8.8.8 c маршрутизатора NetWatch будет переключать маршрут для пользователей интернета с коментарием kam_gw1

/ip route
add check-gateway=ping comment=kontrolnij disabled=no distance=1 dst-address=\
8.8.8.8/32 gateway=192.168.0.1 routing-mark=route-1 scope=30 target-scope=10

Создадим правило маршрутизации в ip route rules для таблицы route-1 и это сделает таблицу маршрутизации для самого роутера однозначной.

Создадим проверку 8.8.8.8 в netwatch на доступность c правилами на падение и подъём хоста:

выключаем маршрут c комментарием kam_gw1 если пинг пропадает:

ip route set [find comment=kam_gw1] disable=yes 

включаем первый маршрут c комментарием kam_gw1 если пинг появляется:

ip route set [find comment=kam_gw1] disable=no

 

 

Прочитано 15723 раз Последнее изменение Вторник, 28 Март 2017 03:13
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by/about/55-kardash-aliaksandr-vladimirovich

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Амина Написал Амина Август 25, 2019 Вот на этом ролторе написано зади логин и пароль Просто я скачала приложение и ьам…
  • Кардаш Александр Владимирович Написал Август 23, 2019 Новая моя статья с замашкой на звание хита по настройке MikroTik!
  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
 rss  vk groupe

 

Нравится ли вам наш блог?

Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промзвязь в Минске
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3


64-ядерный AMD Epyc 7742 — первый в мире процессор, позволяющий кодировать видео 8К по стандарту HEVC в реальном времени
Разработанное Beamr Imaging ПО использовало все 64 ядра CPU в процессе кодирования. Процессоры AMD Epyc нового поколения, и в особенности 64-ядерный Epyc 7742, собрали уже немало восторженных
Windows 10 теперь показывает заряд смартфона и синхронизирует обои
Компания Microsoft ещё раз обновила приложение Your Phone для Windows 10. Теперь эта программа показывает уровень заряда батареи подключённого смартфона, а также синхронизирует обои с мобильным
В ЕС хотят разработать единую цифровую валюту и заблокировать криптовалюту Facebook Libra
Франция выступила с предложением создать европейскую общедоступную цифровую валюту. Об этом заявил министр финансов республики Брюно ле Мэр, передает Reuters. Он не привел никаких деталей, какой
В день запуска одновременное количество игроков в Borderlands 3 вдвое превысило показатель Borderlands 2
Глава Gearbox Software Рэнди Питчфорд похвастался успехами запуска Borderlands 3. Он заявил, что при запуске количество одновременных игроков шутера на PC вдвое превысило показатель предыдущей части.
Новый безвентиляторный неттоп Minix использует платформу Intel Gemini Lake
К выпуску готовится компьютер небольшого форм-фактора Minix NEO G41V-4, образцы которого демонстрировались на недавней выставке электроники IFA 2019 в Берлине (Германия). Неттоп построен на
В Adobe Premiere появится функция автоматической подгонки ширины и высоты видео под разные форматы
Чтобы подогнать видео под разные варианты соотношения сторон, придётся потрудиться. Простое изменение настроек проекта с широкоформатного режима на квадратный не даст нужного результата: поэтому
Франция будет блокировать разработку Facebook Libra
Разрабатываемый Facebook стейблкоин Libra сталкивается с новым препятствием — на этот раз со стороны французского правительства. Министр экономики и финансов страны Бруно Ле Мэр заявил, что Libra
Инструменты для блокировки Telegram проверят в Тюмени
Крупные операторы связи РФ планируют в этом месяце протестировать инструменты для блокировки Telegram. Первый этап — блокирование мессенджера на региональном уровне, а конкретнее — в Тюмени.
«
»
  • 1
  • 2

Авторизация