fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Скрипт переключения каналов интернета и E-mail оповещения на MikroTik

опубликовал от 30 Июль, 2019

Доброго времени суток читателям моего блога. Сегодня выкладываю вариант скрипта для MikroTik на проверку соединения с интернетом WAN1 и отправку e-mail о его падении. Скрипт писал не я, а взят он с рабочего роутера, на котором всё шикарно выполнялось.

C периодичностью 30 секунд надо выполнять скрипт: Назовём его: TestChanel и добавим System/Script

 

:global to "Этот адрес электронной почты защищен от спам-ботов. У вас должен быть включен JavaScript для просмотра."
:global HostPing 77.88.8.8

:global OldTestWan1
:global OldTestWan2

 

:global TestWan1 [([:ping $HostPing count=3 routing-table=wan1_route] > 0)]

:if (($TestWan1 = false) and ($TestWan1 != $OldTestWan1)) do={
/ip route disable [find comment="wan1"]
/log warning "WAN1 is Down"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN1 connection is lost."
} on-error={/log warning "No send Email"}
}

:if (($TestWan1 = true) and ($TestWan1 != $OldTestWan1)) do={
/ip route enable [find comment="wan1"]
/log warning "WAN1 is UP"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN1 connection restored."
} on-error={/log warning "No send Email"}
}

:global TestWan2 [([:ping $HostPing count=3 routing-table=wan2_route] > 0)]

:if (($TestWan2 = false) and ($TestWan2 != $OldTestWan2)) do={
/ip route disable [find comment="wan2"]
/log warning "WAN2 is Down"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN2 connection is lost."
} on-error={/log warning "No send Email"}
}

:if (($TestWan2 = true) and ($TestWan2 != $OldTestWan2)) do={
/ip route enable [find comment="wan2"]
/log warning "WAN2 is UP"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN2 connection restored."
} on-error={/log warning "No send Email"}
}

:set OldTestWan1 $TestWan1
:set OldTestWan2 $TestWan2

 

В IP/Route надо сделать  комментарии для основных маршрутов провайдера 1  - wan1, провайдера 2 - wan2 

Также надо добавить маршруты к 0.0.0.0/0 для WAN1 и WAN2 с марками wan1_route и wan2_route. 

Добавить в IP/Route/Rule правила маршрутизации:

1 route 

В шедуллер добавить правило:

/system script run TestChanel

 

P.S Возможно нужно ещё заполнить в Tools/Email настройки вашего SMTP:

1

 

Прочитано 280 раз Последнее изменение Среда, 07 Август 2019 15:25
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
  • bcloud Написал bcloud Июнь 17, 2019 Добрый день! Подскажите, пожалуйста, как решить проблему. У нас на фирме подключили такой модем, все…
  • Нур Написал Нур Апрель 30, 2019 работает на локалке, а по wifi на телефоне не работает
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по настройке маршрутизаторов MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промсвязь
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3
 rss  vk groupe

 

Нравится ли вам наш блог?


Аналитики вспомнили о предсказаниях Джобса, Безоса и Гейтса, которые исполнились через 20 лет
Три признанных гения инновационных технологий – Стив Джобс, Джеф Безос и Билл Гейтс в разное время смогли предсказать будущее. Аналитики вспомнили о самых важных предсказаниях, которые уже
Эксперт: хромбуки за 999 – это неконкурентный продукт!
После публикации на официальной страничке Chromebook в YouTube видеозаписи, в которой известный ученый и большой шутник Билл Най открыто заявил, что операционная система Windows – это разваливающийся
ВЦИОМ: 48 % россиян никогда не играли в видеоигры, а 33 % — бросили это занятие
Всероссийский центр изучения общественного мнения опросил граждан России в возрасте 18 лет и старше о видеоиграх и получил довольно любопытные материалы. Например, около половины россиян никогда не
AMD жалуется на медленный прогресс в развитии PCI Express
Презентационный материал, который сопровождал выступление главы AMD на Hot Chips, был выложен в профильном разделе сайта компании в тот же день, поэтому у нас есть возможность изучить некоторые
Цены на iPhone не вырастут благодаря Тиму Куку
Когда Тим Кук занял пост генерального директора Apple, многие отнеслись к этому назначению довольно скептически. Очевидно, свою роль сыграло практически полное отсутствие нового CEO в медийном поле.
Мониторинг температуры GPU, обновлённый поиск и смена названий виртуальных рабочих столов — что нового в Windows 10 (18963)
На днях вышла свежая инсайдерская сборка Windows 10 под номером 18963, которая пока доступна в рамках Fast Ring. И в ней, как оказалось, немало интересного. В частности, нововведения включают
Тим Кук пожаловался Трампу: пошлины навредят Apple и помогут Samsung
В прошедшую пятницу глава Apple Тим Кук отужинал вместе с Дональдом Трампом и обсудил американские пошлины на китайский импорт, передает Cnet. Топ-менеджер попытался донести до президента США, что
Раджа Кодури назвал MacBook Air образца 2013 года своим любимым ноутбуком
Курирующий в Intel вопросы разработки графических решений Раджа Кодури (Raja Koduri) на минувших выходных предавался не только ностальгии по временам былого величия ATI, где он успел поработать.
«
»
  • 1
  • 2

Авторизация