fb logo  VK  Feed icon.svg  

Скрипт переключения каналов интернета и E-mail оповещения на MikroTik

опубликовал от 30 Июль, 2019

Доброго времени суток читателям моего блога. Сегодня выкладываю вариант скрипта для MikroTik на проверку соединения с интернетом WAN1 и отправку e-mail о его падении. Скрипт писал не я, а взят он с рабочего роутера, на котором всё шикарно выполнялось.

Для тех кто не хочет тратить своё дорогое время на изучение данного мануала предлагаем нашу платную помощь.

C периодичностью 30 секунд надо выполнять скрипт: Назовём его: TestChanel и добавим System/Script

 

:global to "Этот адрес электронной почты защищен от спам-ботов. У вас должен быть включен JavaScript для просмотра."
:global HostPing 77.88.8.8

:global OldTestWan1
:global OldTestWan2

 

:global TestWan1 [([:ping $HostPing count=3 routing-table=wan1_route] > 0)]

:if (($TestWan1 = false) and ($TestWan1 != $OldTestWan1)) do={
/ip route disable [find comment="wan1"]
/log warning "WAN1 is Down"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN1 connection is lost."
} on-error={/log warning "No send Email"}
}

:if (($TestWan1 = true) and ($TestWan1 != $OldTestWan1)) do={
/ip route enable [find comment="wan1"]
/log warning "WAN1 is UP"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN1 connection restored."
} on-error={/log warning "No send Email"}
}

:global TestWan2 [([:ping $HostPing count=3 routing-table=wan2_route] > 0)]

:if (($TestWan2 = false) and ($TestWan2 != $OldTestWan2)) do={
/ip route disable [find comment="wan2"]
/log warning "WAN2 is Down"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN2 connection is lost."
} on-error={/log warning "No send Email"}
}

:if (($TestWan2 = true) and ($TestWan2 != $OldTestWan2)) do={
/ip route enable [find comment="wan2"]
/log warning "WAN2 is UP"
:do {
/tool e-mail send to=$to subject="HOME - Mikrotik Notification" body="WAN2 connection restored."
} on-error={/log warning "No send Email"}
}

:set OldTestWan1 $TestWan1
:set OldTestWan2 $TestWan2

 

В IP/Route надо сделать  комментарии для основных маршрутов провайдера 1  - wan1, провайдера 2 - wan2 

Также надо добавить маршруты к 0.0.0.0/0 для WAN1 и WAN2 с марками wan1_route и wan2_route. 

Добавить в IP/Route/Rule правила маршрутизации:

1 route 

В шедуллер добавить правило:

/system script run TestChanel

 

P.S Возможно нужно ещё заполнить в Tools/Email настройки вашего SMTP:

1

 

Прочитано 11361 раз Последнее изменение Понедельник, 13 Январь 2020 12:56
Кардаш Александр

Автор статей по настройке ОС и сетевого оборудования. Отвечу на форуме на ваши вопросы. Добрый айтишник! 

Сайт: https://netflow.by/forum/newtopic

Другие материалы с нашего сайта:

Добавить комментарий

Комментарий будет удалён, если не будет содержать осмысленный текст. В тексте сообщения не должно быть бесполезных ссылок на другие сайты.

 rss  vk groupe

 

Трудолюбивый сисадмин
 Корпоратив. Турбаза. Домик с русской печкой. с охапкой дров входит наш админ. В голове тут же мысль: "всё правильно - пришёл админ, принёс дрова..."
Установить?
Страшный сон линуксоида: sudo apt-get install amigo Построение дерева зависимостей.. Будут установлены следующие пакеты: amigo-browser mail-agent mail-cloud mail-sputnik mail-guard chromium-yandex-bar firefox-yandex-bar odnoklassniki-panel1.0.1  
Анекдот дня
Если программа работает не так, как написано в инструкции к ней - то ошибка может быть и там, и там. Согласно народной примете, в новый дом первым нужно впускать интернет-кабель. И где он ляжет - там ставьте кровать. И стол. И комп. И жрачку На русификацию новой версии Windоws было потрачено
На самом деле это его идея
Звонок на фирму которая занимается ремонтом компьютеров:— Мой принтер начал плохо печатать!— Вероятно его надо просто почистить. Это стоит 50. Но для вас будет лучше если вы прочтете инструкцию и выполните эту работу сами.Клиент удивленный такой откровенностью спрашивает:— А ваш босс знает что вы
«
»
  • 1
  • 2
  • 3
  • 4
  • 5


Нравится ли вам наш блог?

Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги переустановки Windows с выездом в офис
Переустановка Windows на дому и офисе с выездом по Минску весьма востребованная услуга. Иногда ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных
Услуги ремонта компьютеров с выездом в офис
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги настройки Wi-Fi сети на дому и в офисе
Настроим любые Wi-Fi роутеры с выездом к вам на дом или в офис по Минску. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и
Услуги по настройке модемов на дому и в офисе
Настроим роутеры белорусских интернет провайдеров с выездом на дом и в офис по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако
Услуги восстановления данных с выездом в офис
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску и удалённо. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши
Услуги переустановки и настройки программ в офисе
Для начинающих пользователей Windows и Mac мы предлагаем услуги переустановки и настройки популярного программного обеспечения с выездом по Минску и удалённо. Мы можем переустановить на Вашем
Услуги настройки и обслуживания локальных сетей
Настройка локальной сети в Минске является ответственным этапом запуска сетей и требует тщательной проработки квалифицированными специалистами. Локальные сети (проводные и беспроводные) дают
Услуги настройки роутеров в офисе и на дому
Использование маршрутизатора (англ. router) возможно только после его правильной настройки, а это не так уж и просто. Как правило нет опредёлённой методологии для осуществления настройки, ведь
Услуги чистки ноутбуков от пыли в офисе
Одна из самых распространенных неисправностей ноутбука является перегрев из-за забившейся пылью системы охлаждения. В следствии чего ноутбук тормозит, а порой даже выключается.  Если Ваш
Услуги настройки интернета с выездом в офис
Окажем помощь в настройке интернета на самых разных устройствах: телевизорах, планшетах, ноутбуках, стационарных компьютерах и мобильных телефонах с выездом по городу. Настроим роутеры и модемы у
Услуги приходящего системного администратора
Как показывает практика, содержание в штате сотрудников, выполняющих администрирование компьютеров очень затратно. Позволить себе это могут в основном крупные компании. Если Вы не относитесь к
«
»
  • 1
  • 2
Пользователи Windows 11 сообщают о новых багах - у них остаются старые меню пуск и панель управления
Многочисленные специалисты в сети интернет не единожды рекомендовали не торопиться устанавливать новую операционную систему Windows 11, ссылаясь на негативный опыт прошлых выпусков, а советовали
Через пару лет у Seagate будут готовы жёсткие диски объёмом 30 Тбайт
Представители ресурса Tom’s Hardware удосужились изучить стенограмму выступления финансового директора Seagate Technology Джанлуки Романо (Gianluca Romano) на мероприятии Citi Global Technology
Появилось фото реального процессорного разъёма Intel LGA 1700
Процессорный разъём LGA 1700, которому суждено до конца этого года приютить процессоры Intel семейства Alder Lake-S, до сих пор появлялся преимущественно на чертежах и схематических изображениях, но
Team Group наглядно продемонстрировала различия между DDR5 и DDR4
Смена поколений оперативной памяти происходит не так часто, а потому компания Team Group уцепилась за этот информационный повод, чтобы привлечь к своей продукции дополнительное внимание клиентов. На
«
»
  • 1
  • 2

Авторизация