fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Скрипт DHCP-клиента для создания маркированного маршрута в MikroTik

опубликовал от 09 Ноябрь, 2018

Скрипт записан после \n . Создаёт дефолтный маршрут с указанной Routing Mark, при этом в шлюзе указывается IP-адрес.

Для создание DHCP клиента сo скриптом добавляющим маркированный маршрут в таблицу выполните в терминале следующую команду:

/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=ether2 script="{\r\
    \n    :local rmark \"WAN1\"\r\
    \n    :local count [/ip route print count-only where comment=\"WAN1\"]\r\
    \n    :if (\$bound=1) do={\r\
    \n        :if (\$count = 0) do={\r\
    \n            /ip route add gateway=\$\"gateway-address\" comment=\"WAN1\" routing-mark=\$rmark\r\
    \n        } else={\r\
    \n            :if (\$count = 1) do={\r\
    \n                :local test [/ip route find where comment=\"WAN1\"]\r\
    \n                :if ([/ip route get \$test gateway] != \$\"gateway-address\") do={\r\
    \n                    /ip route set \$test gateway=\$\"gateway-address\"\r\
    \n                }\r\
    \n            } else={\r\
    \n                :error \"Multiple routes found\"\r\
    \n            }\r\
    \n        }\r\
    \n    } else={\r\
    \n        /ip route remove [find comment=\"WAN1\"]\r\
    \n    }\r\
    \n}\r\
    \n"

Работает на версиях Router OS от 6.39rc33 и более свежих...
Можно вставить в поле скрипта DHCP клиента этот код:

{
:local rmark "WAN1"
:local count [/ip route print count-only where comment="WAN1"]
:if ($bound=1) do={
:if ($count = 0) do={
/ip route add gateway=$"gateway-address" comment="WAN1" routing-mark=$rmark
} else={
:if ($count = 1) do={
:local test [/ip route find where comment="WAN1"]
:if ([/ip route get $test gateway] != $"gateway-address") do={
/ip route set $test gateway=$"gateway-address"
}
} else={
:error "Multiple routes found"
}
}
} else={
/ip route remove [find comment="WAN1"]
}
}

Основано на официальном wiki

Обучение: Как настроить MikroTik с нуля?

Научитесь работать с оборудованием MikroTik и RouterOS по видеокурсу «Настройка оборудования MikroTik». Проходите уроки в комфортном темпе и когда удобно – все материалы остаются у вас бессрочно. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект. Пройдя курс, вы сможете настроить маршрутизатор MikroTik с нуля, даже если у вас не будет в наличии реального оборудования. Начало курса можно посмотреть бесплатно, оставив заявку здесь.

Прочитано 3444 раз Последнее изменение Пятница, 09 Ноябрь 2018 17:12
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
  • bcloud Написал bcloud Июнь 17, 2019 Добрый день! Подскажите, пожалуйста, как решить проблему. У нас на фирме подключили такой модем, все…
  • Нур Написал Нур Апрель 30, 2019 работает на локалке, а по wifi на телефоне не работает
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по настройке маршрутизаторов MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промсвязь
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3
 rss  vk groupe

 

Нравится ли вам наш блог?


Аналитики вспомнили о предсказаниях Джобса, Безоса и Гейтса, которые исполнились через 20 лет
Три признанных гения инновационных технологий – Стив Джобс, Джеф Безос и Билл Гейтс в разное время смогли предсказать будущее. Аналитики вспомнили о самых важных предсказаниях, которые уже
Эксперт: хромбуки за 999 – это неконкурентный продукт!
После публикации на официальной страничке Chromebook в YouTube видеозаписи, в которой известный ученый и большой шутник Билл Най открыто заявил, что операционная система Windows – это разваливающийся
ВЦИОМ: 48 % россиян никогда не играли в видеоигры, а 33 % — бросили это занятие
Всероссийский центр изучения общественного мнения опросил граждан России в возрасте 18 лет и старше о видеоиграх и получил довольно любопытные материалы. Например, около половины россиян никогда не
AMD жалуется на медленный прогресс в развитии PCI Express
Презентационный материал, который сопровождал выступление главы AMD на Hot Chips, был выложен в профильном разделе сайта компании в тот же день, поэтому у нас есть возможность изучить некоторые
Цены на iPhone не вырастут благодаря Тиму Куку
Когда Тим Кук занял пост генерального директора Apple, многие отнеслись к этому назначению довольно скептически. Очевидно, свою роль сыграло практически полное отсутствие нового CEO в медийном поле.
Мониторинг температуры GPU, обновлённый поиск и смена названий виртуальных рабочих столов — что нового в Windows 10 (18963)
На днях вышла свежая инсайдерская сборка Windows 10 под номером 18963, которая пока доступна в рамках Fast Ring. И в ней, как оказалось, немало интересного. В частности, нововведения включают
Тим Кук пожаловался Трампу: пошлины навредят Apple и помогут Samsung
В прошедшую пятницу глава Apple Тим Кук отужинал вместе с Дональдом Трампом и обсудил американские пошлины на китайский импорт, передает Cnet. Топ-менеджер попытался донести до президента США, что
Раджа Кодури назвал MacBook Air образца 2013 года своим любимым ноутбуком
Курирующий в Intel вопросы разработки графических решений Раджа Кодури (Raja Koduri) на минувших выходных предавался не только ностальгии по временам былого величия ATI, где он успел поработать.
«
»
  • 1
  • 2

Авторизация