fb logo  VK  Feed icon.svg  

Аппаратный сброс USB модема при зависании в MikroTik

опубликовал от 22 Май, 2016

Зачастую не все USB 3G/4G модемы работают с маршрутизаторами стабильно. Выясняется, что даже программная перезагрузка MikroTik не позволяет их вывести из ступора. К счастью в некоторых Routerboard предусмотрено отключение питания USB порта на какое-то время. Сегодня мы рассмотрим как сделать аппаратный сброс модема программными средствами роутера. 

Для тех кто не хочет тратить своё дорогое время на изучение данного мануала предлагаем нашу платную помощь.

Комманду сброса питания USB порта нужно добавить в Tools->Netwatch в поле Down. Проверять доступность лучше всего DNS компании Google - 8.8.8.8 или 8.8.4.4. 

 

/system routerboard usb power-reset duration=15s 

 

Если интернет на маршрутизаторе пропадёт, через минуту Netwatch отключит питание от USB порта на 15 секунд

Проверялось работа комманды на RB951Ui-2nD. В старых аппартных версиях MikroTik mAP-2n - комманда не работает.

 

Если часты случаи что модем после срабатывания Netwatch по каким либо причинам не поднимется лучше выполнить скрипт по расписанию:

 

/system scheduler

add interval=1m30s name=schedule1 on-event="/system script run script1" policy=
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup

/system script

add name=script1 owner=admin policy=
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":local PINGRESU
LT1 ;

 

:if ($PINGRESULT1 > 0) do={

:log info message="USB-ZDES";

} else={

:log info message="USB-Broken!!!";

/system routerboard usb power-reset duration=10s;

}"
12
12
item
196
1

Прочитано 53171 раз Последнее изменение Вторник, 06 Октябрь 2020 16:23
Кардаш Александр

Автор статей по настройке ОС и сетевого оборудования. Отвечу на форуме на ваши вопросы. Добрый айтишник! 

Сайт: https://netflow.by/forum/newtopic

Другие материалы с нашего сайта:

Комментарии   

MaKs
# 0 MaKs 12.03.2020 17:21
i.mt.lv/cdn/rb_files/mAP-140813152402.pdf
microUSB type AB with power reset capability, for 3G/4G modem, storage or powering
Ответить
ИгорьЧ
# 0 ИгорьЧ 25.08.2019 00:22
А если проверять доступность web-интерфейса модема, а не DNS? Когда модем подвисает, web-интерфейс перестает отвечать.

Ответ: Не всегда так... Видимо модем может подвисать и при этом пинговаться...
Ответить
ss-18
# 0 ss-18 12.08.2019 22:00
Аппаратный ватчдог надо ставить чтоб он перезагружал микротик при пропадании интернета. Надо чтоб он пингавал сам микротик на случай если он зависнет. А чтоб соединение интернета переподключал лучше написать небольшой скрипт.

Ответ: Сам MikroTik если он исправен конечно - никогда не зависает... На 3G модеме переподключение интернета ничего не даёт... Так что этот скрипт рулёзная вещь...
Ответить
Владимир
# 0 Владимир 24.02.2019 10:45
Однажды днс гугла походу заглючил и при нормальном и работющем соединении с доступным интернетом, тик стал перезагружаться (но у меня был настроен ватчдогс на днс гугла), т.е. не было пинга с 8.8.8.8 , однако интернет был, это можно было понять в паузах между перезагрузками. Пришлось отказаться от этой идеи, если сервер ляжет на том конце ваше устройство будет циклично перезапускаться или перезапускать модем как в данной статье. Тогда он у меня 6 раз перезагрузился, пока не удалось выявить причину и быстро влезть в ватчдогс и отрубить.

Ответ: В данной статье скрипт не перезагружает роутер. Скрипт производит однократный сброс питания на модеме. Если DNS гугла перестанет быть доступен он один раз сбросит питание и успокоится......
Ответить
Борис
# 0 Борис 16.05.2017 10:20
Спасибо!
Ответить

Добавить комментарий

Комментарий будет удалён, если не будет содержать осмысленный текст. В тексте сообщения не должно быть бесполезных ссылок на другие сайты.

 rss  vk groupe

 

Программа не продаётся
У сисадмина спрашивают:- А вы часто по порносайтам ползаете?- Нет, все необходимое в кэше нахожу.
Повысим квалификацию?
Админы обычно живут в однокомнатных квартирах на окраине Москвы. В квартире есть компьютер, электрический чайник, банка кофе и микроволновка, в которой админ готовит пиццу. Больше админу ничего не нужно.
Сама я не месная
- Ты Фотошопить умеешь?- Не, только Корелдрочить.
«
»
  • 1
  • 2
  • 3
  • 4
  • 5

Нравится ли вам наш блог?

Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги переустановки Windows с выездом в офис
Переустановка Windows на дому и офисе с выездом по Минску весьма востребованная услуга. Иногда ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных
Услуги настройки Wi-Fi сети на дому и в офисе
Настроим любые Wi-Fi роутеры с выездом к вам на дом или в офис по Минску. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и
Услуги ремонта компьютеров с выездом в офис
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги по настройке модемов на дому и в офисе
Настроим роутеры белорусских интернет провайдеров с выездом на дом и в офис по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако
Услуги установки и настройки свободных программ
Для начинающих пользователей Windows и Mac мы предлагаем услуги установки и настройки свободного программного обеспечения с выездом по Минску в офис. Предлагаем вам установить: пакет офисных
Услуги настройки роутеров в офисе и на дому
Использование маршрутизатора (англ. router) возможно только после его правильной настройки, а это не так уж и просто. Как правило нет опредёлённой методологии для осуществления настройки, ведь
Услуги настройки и обслуживания локальных сетей
Настройка локальной сети в Минске является ответственным этапом запуска сетей и требует тщательной проработки квалифицированными специалистами. Локальные сети (проводные и беспроводные) дают
Услуги монтажа локальной вычислительной сети
Прокладка локальных сетей это комплексная работа, которая выполняется нашими специалистами качественно, продуманно и в сроки, четко оговоренные с заказчиком. На сегодняшний день, прокладка
Услуги чистки ноутбуков от пыли в офисе
Одна из самых распространенных неисправностей ноутбука является перегрев из-за забившейся пылью системы охлаждения. В следствии чего ноутбук тормозит, а порой даже выключается.  Если Ваш
Услуги приходящего системного администратора
Как показывает практика, содержание в штате сотрудников, выполняющих администрирование компьютеров очень затратно. Позволить себе это могут в основном крупные компании. Если Вы не относитесь к

Авторизация