fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Настройка Firewall на MikroTik. Описание правил фильтрации.

опубликовал от 28 Июнь, 2013

Межсетевой экран, брендмауэр или Firewall выполняет фильтрацию пакетов являясь таким образом инструментом обеспечивающим безопасность и управление потоками данных, проходящими через маршрутизатор. Вместе с трансляцией сетевых адресов NAT файервол служит инструментом предотвращения несанкционированного проникновения в сеть компании. Возможно и наоборот применением фильтрации пакетов совместно с транспарентными Proxy серверами и NAT добиться запрета на использование определённых ресурсов и внешних сетей. Полезно Firewall использовать для ограничения доступа к заведомо незащищенным службам. Он может служить препятствием для внедрения ложных данных с помощью уязвимых служб злоумышленником. Также через него возможен контроль доступа к узлам сети, регистрирование попыток доступа как извне, так и из внутренней сети. Можно регламентировать порядок доступа к сети, осуществлять уведомление о подозрительной деятельности, попытках зондирования или атаки на узлы сети или сам экран. 

Файервол Mikrotik RouterOS обладает мощными функциями и включает следующие возможности:

• Фильтрация пакетов; 
• Фильтрация p2p протоколов
• Классификация трафика по:
o исходный MAC-адрес;
o IP-адрес (сеть или список) и тип адреса (бродкаст, локальный, мультикаст, юникаст);
o Порт или список портов;
o IP-протокол;
o Опции протокола (ICMP тип и другие коды, TCP флаги, IP опции и MSS)
o Интерфейс, откуда получен пакет или куда он назначается
o Внутренний поток или маркированное подключение
o Байт ToS (DSCP)
o Содержимое пакета
o Скорость получения пакетов и количество последовательностей
o Размер пакета
o Время получения пакета

Основные принципы фильтрации
Оперирование файерволом осуществляется посредством правил. Правило определяет выражение, которое говорит роутеру что делать с индивидуальным IP-пакетом. Каждое правило состоит из двух частей: первое описывает параметры, по которым должны классифицироваться приходящие пакеты, второе отвечает за действие над пакетом. Правила, для лучшего управления, организованы в цепочки.
Устройство фильтра по-умолчанию имеет три цепочки: input, forward и output, которые отвечают за приходяший, перемещаемый внутри роутера и исходящий трафик соответственно. Пользователь может добавить новые цепочки, если это будет нужно.
Под эти цепочки трафик по-умолчанию не попадает. Для этого используется метод action=jump с параметром jump-target в одной из предустановленных цепочек.
Цепочки фильтра
Как говорилось раньше, правила фильтрации в файерволе сгруппированы в цепочки. Это позволяет пакету попавшему под некий критерий в одной цепочке переходить к следующему правилу и следующим цепочкам. К примеру пакетам с определённого адреса и порта нужно применить много правил. Конечно, эти правила можно перечислить в цепочке forward, однако правильнее будет создать для них отдельную цепочку, перебросить туда попавшие под условие пакеты и выполнить над ними нужные нам действия: /ip firewall filter add src-address=1.1.1.2/32 jump-target="mychain". Это правило создаст новую цепочку mychain, в которую попадут все пакеты с адресом источника 1.1.1.2/32.
Три предустановленных цепочки, которые не могут быть удалены:
• Input-применимо к пакетам, приходящим на маршрутизатор, у которых адрес получателя такой же, как и у интерфейса, на который этот пакет поступил. Пакеты, проходящие через маршрутизатор не попадают под действие правил цепочки input.
• Forward – применимо к пакетам, проходящим через маршрутизатор;
• Output – применимо к пакетам созданным маршратизатором, которые покидают его через один из интерфейсов. Пакеты, проходящие через маршрутизатор не попадают под действие цепочки output.
При попадании пакета в одну из цепочек, правила применяются от верхего к нижнему. Если пакет попадает под критерий одного из правил, над ним выполняется указанное в правиле действие и этот пакет не попадает больше под действие других правил из этой цепочки (исключение составляет только действие passthrough). Если пакет не попадает под действие ни одного из правил цепочки, к нему по умолчанию применяется действие Accept.
Описание параметров:
action (accept | add-dst-to-address-list | add-src-to-address-list | drop | jump | log | passthrough | reject | return | tarpit; default: accept) – применяемое действие, если пакет совпал с правилом
accept – принять пакет. Не подразумевает каких-либо действий. Если пакет был принят, к нему больше не применяется никаких действий в цепочке.
add-dst-to-address-list – добавить адрес назначения пакета в address list , указанный в параметре address-list
add-src-to-address-list - добавить адрес источника пакета в address list , указанный в параметре address-list
drop – разрушить пакет (без посылки сообщения ICMP reject)
jump – перепрыгнуть в цепочку, указанную в параметре jump-target
log – каждое совпадение с этим действием добавит в системный лог сообщение
passthrough – игнорировать это правило и перейти к следующему
reject –отбросить этот пакет и постать сообщение ICMP reject
return – вернуть пакет в цепочку, из которой он был переброшен
tarpit – захватить и удерживать входящие TCP подключения (отвечать SYN/ACK на входящий TCP SYN пакет)
address-list (name) – указывает имя списка адресов, в которых хранятся IP-адреса из действий action=add-dst-to-address-list или action=add-src-to-address-list. Эти списки могут быть похже использованы в других правилах.
address-list-timeout (time; default: 00:00:00) – интервал времени, через который адреса будут удалены из списка, указанного в параметре address-list . Используется в сочетании с действиями add-dst-to-address-list или add-src-to-address-list .00:00:00 – означает оставить адреса в списке навсегда.
chain (forward | input | output | name) – указывает цепочку, в которую следует поместить правило. Разные типы трафика проходят через разные цепочки, поэтому будьте в курсе своего выбора, указывая то или иное значение этого параметра. Если указанное значение цепочки не совпадает ни с одним из уже существующих, система создаст новое правило с указанным именем.
comment (text) – комментарий описывает правило. В скриптах комментарии обычно служат для идентификации правил.
connection-bytes (integer-integer) – применять правило, если количество переданных байт через подключение превысило указанное значение. 0 – не ограничено, пример: connection-bytes=2000000-0 сработает в том случае, если количество данных, переданных через открытое подключение превысило 2MB;
connection-limit (integer,netmask) – ограничивает количество доступных подключений на адрес или блок адресов;
connection-mark (name) –пакеты, попавшие под действие правил в mangle и названные в соответствии с параметром connection mark
connection-state (established | invalid | new | related) – интерпретация состояния подключения посредством анализа данных из connection tracking .
established – пакет, принадлежащийa уже установленному подключению. К примеру ответ от маршрутизатора.
invalid – пакет, который не может быть идентифицирован по какой-либо причине. К примеру это может быть переполнение памяти и ICMP ошибки. К таким пакетам нужно применять действие DROP
new – пакет, начинающий создание TCP подключения
related – запрошенный пакет, который не принадлежит уже установленным подключениям. К примеру ICMP ошибки, или пакет, начинающий передачу данных по протоколу FTP( /ip firewall service-port)
connection-type (ftp | gre | h323 | irc | mms | pptp | quake3 | tftp) – определение типа подключения, базирующееся на использовании данных из connection tracking. Конфигурирование производится в /ip firewall service-port
content (text) – содержимое текстового пакета
dst-address (IP address/netmask | IP address-IP address) – указывает диапазон адресов, у которых IP-адрес назначения совпадает с параметром. При неправильном введении пары address/netmask система сама подстроит эти параметры. К примеру:1.1.1.1/24 будет заменено на 1.1.1.0/24
dst-address-list (name) – совпадение адреса назначения пакета с определенными ранее значениями в address list
dst-address-type (unicast | local | broadcast | multicast) – совпадение типа адреса назначения пакета с заданным предустановленным значением:
unicast – IP-адреса, используемые ля передачи от одной точки к другой. В таком типе пакетов существует только один отправитель и один получатель
local – совпадеине с адресами, назначенными сетевым интерфейсам маршрутизатора
broadcast – IP-пакет, посылаемый сразу всем членам подсети
multicast – этот тип пакета используется для передачи данных от одного отправителя многим получателям в сети.
dst-limit (integer/time{0,1},integer,dst-address | dst-port | src-address{+},time{0,1}) – ограничивает скорость пакетов в секунду (packet per second (pps)) на IP-адрес или порт.
В результате работы правила каждый IP-адрес или порт назначения получает свой лимит.
Параметр имеет следующие опции:
Count – среднее количество пакетов в секунду (packets per second (pps))за время Time
Time – интервал времени, за который производится подсчёт среднего количества пакетов
Burst – количество пакетов в пике
Mode – классификатор для ограничения скорости пакетов
Expire - указывает интервал, через который записанные IP адреса /порты будут удалены
dst-port (integer: 0..65535-integer: 0..65535{*}) – интервал портов назначения
hotspot (multiple choice: from-client | auth | local-dst | http) – сравнивает пакеты полученные от клиентов с различными хот-спотами. все значения могут быть отклонены/инвертированы
from-client - true, если пакеты получены от Hot-Spot клиента
auth - true, если пакеты получены от авторизированного Hot-Spot клиента
local-dst - true, если пакет имеет локальный адрес назначения
hotspot - true, если TCP пакет от клиента и назначается на 80 порт прозрачного прокси сервера или клиент имеет адрес прокси сконфигурированный и аналогичный адресу:порту пакета
icmp-options (integer:integer) - совпадение полей ICMP Type:Code
in-interface (name) – интерфейс, с которого пакет поступил в маршратизатор
ipv4-options (any | loose-source-routing | no-record-route | no-router-alert | no-source-routing | no-timestamp | none | record-route | router-alert | strict-source-routing | timestamp) – совпадение параметров заголовка ipv4
any – совпадает по крайней мере один пакет с установленной ipv4 опцией
loose-source-routing – пакеты с опцией loose source routing. Эта опция используется для направления интернет дейтаграм основаных на информации поставляемой источником
no-record-route – пакеты с опцией no record route. Эта опция используется для направления интернет дейтаграм основаных на информации поставляемой источником
no-router-alert – совпадение пакетов с опцией no router alter
no-source-routing – совпадение пакетов с опцией no source routing
no-timestamp – совпадение пакетов с опцией with no timestamp
record-route – совпадение пакетов с опцией record route
router-alert - совпадение пакетов с опцией router alter
strict-source-routing - совпадение пакетов с опцией strict source routing
timestamp – совпадение пакетов со штампом времени
jump-target (forward | input | output | name) – имя целевой цепочки куда должен быть отправлен пакет при использовании action=jump.
limit (integer/time{0,1},integer) – ограничивает поток пакетов. Используется для уменьшения количества сообщений в логах
Count – максимальное среднее количество пакетов, указанное в пакетах в секунду (PPS Packet Per Second) за время в опции Time
Time – указывает интервал времени за который будет производиться подсчёт среднего количества пакетов
Burst – количество пакетов при пике
log-prefix (text) – все сообщения, записываемые в лог, будут иметь этот префикс. Используется вместе с опцией action=log
nth (integer,integer: 0..15,integer{0,1}) – совпадение каждого n-ного пакета, попавшего в правило. Всего доступно 16 счётчиков
Every – совпадение каждого Every+1th пакета. К примеру, если Every=1 тогда под действие правила попадёт каждый второй пакет
Counter – указывает какой счётчик будет использоваться. Счётчик увеличивается на 1 с каждым новым правилом где указанна опция nth
Packet -совпадает с номером данного пакета. Значение по очевидным причинам должно быть между нулем и Every. Если опиция используется для данного счетчика, тогда должно быть по крайней мере Every+1 правило с этой опцией, охватывающее все значения между 0 и Every включительно out-interface (name) – интерфейс, через который пакеты будут покидать маршрутизатор
p2p (all-p2p | bit-torrent | blubster | direct-connect | edonkey | fasttrack | gnutella | soulseek | warez | winmx) – совпадение пакетов протоколов peer-to-peer (P2P)
packet-mark (text) – цепочка пакетов, промаркированная в разделе mangle файервола
packet-size (integer: 0..65535-integer: 0..65535{0,1}) – размер пакета в байтах
Min – указывает нижний предел диапазона размера пакета
Max - указывает верхний предел диапазона размера пакета

phys-in-interface (name) – физический интерфейс, указанный в качестве порта моста, по которому пакет поступил в маршрутизатор
phys-out-interface (name) - физический интерфейс, указанный в качестве порта моста, по которому пакет выйдет из маршрутизатора
protocol (ddp | egp | encap | ggp | gre | hmp | icmp | idrp-cmtp | igmp | ipencap | ipip | ipsec-ah | ipsec-esp | iso-tp4 | ospf | pup | rdp | rspf | st | tcp | udp | vmtp | xns-idp | xtp | integer) – совпадение IP протокола. Указывается имя протокола или его номер. Вы должны указать эту опцию, чтобы получить доступ к специфическим параметрам для каждого протокола.
psd (integer,time,integer,integer) – попытка определения сканирования TCP и UDP портов. Необходимо назначить меньшее значение портам с высокими номерами для того, чтобы уменьшить количество ложных срабатываний. К примеру, при использовании пассивного режима FTP.
WeightThreshold – полный вес последних TCP/UDP пакетов с различными портами назначения, поступающими с одного хоста, которые распознанные как один из методов сканирования
DelayThreshold – задержка между пакетами с разными портами назначения, поступающие с одного хоста и распознанные как возможная последовательность сканирования
LowPortWeight – вес пакетов при сканировании привилегированных портов (<=1024)
HighPortWeight – вес пакетов на непривилегированные порты назначения
random (integer: 1..99) – совпадение пакетов с заданным уровнем случайности
reject-with (icmp-admin-prohibited | icmp-echo-reply | icmp-host-prohibited | icmp-host-unreachable | icmp-net-prohibited | icmp-network-unreachable | icmp-port-unreachable | icmp-protocol-unreachable | tcp-reset | integer) – указывает причину по которой был отброшен пакет в action=reject
routing-mark (name) – совпадение пакетов, обозначенных в цепочке mangle параметром routing mark
src-address (IP address/netmask | IP address-IP address) – указывает диапазон адресов IP пакетов поступивших извне. Замечание: консоль конвертирует неправильно набранные IP значения address/netmask в правильный сетевой адрес. К примеру:1.1.1.1/24 будет конвертирован в 1.1.1.0/24
src-address-list (name) – совпадение адреса источника с списком IP-адресов в предустановленном пользователе address list
src-address-type (unicast | local | broadcast | multicast) – совпадение типа IP-адреса:
unicast - IP адрес используется для передачи данных между двумя узлами, где только один отправитель и один получатель
local – совпадение адреса, назначенного одному из интерфейсов маршрутизатора
broadcast - IP пакет был отправлен из одной точки всем получателям и IP подсети
multicast – этот типа IP адресации ответственен за передачу между одной или несколькими точками одной или набору других точек
src-mac-address (MAC address) - MAC адрес источника
src-port (integer: 0..65535-integer: 0..65535{*}) – диапазон портов источника
tcp-flags (ack | cwr | ece | fin | psh | rst | syn | urg) - tcp флаги
ack – запрос данных
cwr – принимающее окно уменьшено
ece - ECN-флаг echo (explicit congestion notification)
fin – закрытие подключения
psh – функция push
rst – разорвать подключение
syn – новое подключение
urg - urgent data
tcp-mss (integer: 0..65535) - совпадение значения TCP MSS IP пакета
time (time-time,sat | fri | thu | wed | tue | mon | sun{+}) – позволяет создать фильтр, базирующийся на времени получения пакета или дате. Для локально созданных пакетов дате отправки
tos (max-reliability | max-throughput | min-cost | min-delay | normal) – совпадение с полем «тип сервиса» Type of Service (ToS) в IP загаловке
max-reliability – максимальная надёжность (ToS=4)
max-throughput – максимальная пропускная способность (ToS=8)
min-cost – минимальная стоимость (ToS=2)
min-delay – минимальная задержка (ToS=16)
normal – нормальное обслуживание (ToS=0)

Правила NAT применяются первыми, и это нужно помнить при создании правил файервола, так как оригинальные пакеты могли быть модифицированы в NAT.

Примеры применения:
Защита вашего маршрутизатора RouterOS
Для защиты вашего маршрутизатора сменить пароль администратора недостаточно и нужно воспользоваться фильтрацией пакетов. Все пакеты с адресом назначения маршрутизатора попадают во входную цепочку файервола INPUT. Заметьте, что попавшие в цепочку INPUT пакеты не будут проходить через маршрутизатор.

/ip firewall filter 
add chain=input connection-state=invalid action=drop \
comment="Drop Invalid connections"
add chain=input connection-state=established action=accept \
comment="Allow Established connections"
add chain=input protocol=udp action=accept \
comment="Allow UDP"
add chain=input protocol=icmp action=accept \
comment="Allow ICMP"
add chain=input src-address=192.168.0.0/24 action=accept \
comment="Allow access to router from known network"
add chain=input action=drop comment="Drop anything else"

Для защиты сети проверяется весь трафик проходящий через маршрутизатор и блокировать нежелательные пакеты:

/ip firewall filter
add chain=forward protocol=tcp connection-state=invalid \
action=drop comment="drop invalid connections"
add chain=forward connection-state=established action=accept \
comment="allow already established connections"
add chain=forward connection-state=related action=accept \
comment="allow related connections"

Блокировать IP адреса, названные "bogons":
add chain=forward src-address=0.0.0.0/8 action=drop
add chain=forward dst-address=0.0.0.0/8 action=drop
add chain=forward src-address=127.0.0.0/8 action=drop
add chain=forward dst-address=127.0.0.0/8 action=drop
add chain=forward src-address=224.0.0.0/3 action=drop
add chain=forward dst-address=224.0.0.0/3 action=drop

Перебросить их в другую цепочку:
add chain=forward protocol=tcp action=jump jump-target=tcp
add chain=forward protocol=udp action=jump jump-target=udp
add chain=forward protocol=icmp action=jump jump-target=icmp

Создать цепочку tcp и запретить некоторые tcp порты:
add chain=tcp protocol=tcp dst-port=69 action=drop \
comment="deny TFTP"
add chain=tcp protocol=tcp dst-port=111 action=drop \
comment="deny RPC portmapper"
add chain=tcp protocol=tcp dst-port=135 action=drop \
comment="deny RPC portmapper"
add chain=tcp protocol=tcp dst-port=137-139 action=drop \
comment="deny NBT"
add chain=tcp protocol=tcp dst-port=445 action=drop \
comment="deny cifs"
add chain=tcp protocol=tcp dst-port=2049 action=drop comment="deny NFS"
add chain=tcp protocol=tcp dst-port=12345-12346 action=drop comment="deny NetBus"
add chain=tcp protocol=tcp dst-port=20034 action=drop comment="deny NetBus"
add chain=tcp protocol=tcp dst-port=3133 action=drop comment="deny BackOriffice"
add chain=tcp protocol=tcp dst-port=67-68 action=drop comment="deny DHCP"

Запретить udp порты в цепочке udp:
add chain=udp protocol=udp dst-port=69 action=drop comment="deny TFTP"
add chain=udp protocol=udp dst-port=111 action=drop comment="deny PRC portmapper"
add chain=udp protocol=udp dst-port=135 action=drop comment="deny PRC portmapper"
add chain=udp protocol=udp dst-port=137-139 action=drop comment="deny NBT"
add chain=udp protocol=udp dst-port=2049 action=drop comment="deny NFS"
add chain=udp protocol=udp dst-port=3133 action=drop comment="deny BackOriffice"

Разрешить только необходимые коды icmp в цепочке с именем icmp:
add chain=icmp protocol=icmp icmp-options=0:0 action=accept \
comment="drop invalid connections"
add chain=icmp protocol=icmp icmp-options=3:0 action=accept \
comment="allow established connections"
add chain=icmp protocol=icmp icmp-options=3:1 action=accept \
comment="allow already established connections"
add chain=icmp protocol=icmp icmp-options=4:0 action=accept \
comment="allow source quench"
add chain=icmp protocol=icmp icmp-options=8:0 action=accept \
comment="allow echo request"
add chain=icmp protocol=icmp icmp-options=11:0 action=accept \
comment="allow time exceed"
add chain=icmp protocol=icmp icmp-options=12:0 action=accept \
comment="allow parameter bad"
add chain=icmp action=drop comment="deny all other types"

 Данный перевод был сделан для RouterOS v2.9.31. С того времени кое-что изменилось.

 Можно так-же посмотреть видео от профессионала:

 

Прочитано 113655 раз Последнее изменение Воскресенье, 01 Июль 2018 13:11
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by/about/55-kardash-aliaksandr-vladimirovich

Другие материалы с нашего сайта:

2 Комментарии

  • Володя

    Спасибо большое за статью. Возникла проблема, в логах постоянно появляется: login failure for user root from . . . . . via telnet. была проблема до этого с 22 портом я его перекинул только на локальную сеть, а что делать с 23 портом? закрыть? или можно как-то настроить что бы не лезли?

    Ответ: Перекиньте и его только на локалку, или в input firewall filter закройте порт тсп 22 и 23!

    Володя   Пятница, 16 Май 2014 08:48
  • Дмитрий

    Большое спасибо за статью, очень полезно.

    Дмитрий   Воскресенье, 22 Сентябрь 2013 16:43

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

Ура :-)
Благодаря американской компьютеризированной системе выборов президента, тысячи российских хакеров смогли принять участие в голосовании…
Что делает сисадмин?
Сисадмин сидит в баре и хлещет пиво.Подходит к нему девица и спрашивает:— Молодой человек, а сколько сейчас времени, хи-хи, не подскажете?Сисадмин берет ее за руку, показывает на часы на ее руке и с ненавистью в голосе говорит:— ВОТ ЗДЕСЬ... ВСЕ.... НАПИСАНО!!!
Анегдот дня
В черном-черном городе, на черной-черной улице, в черном-черном доме, в черно-черной квартире сидит черный-черный мужик и говорит: - Никогда больше не буду сам заправлять картриджи!  
Работа программиста и шамана похожа
Работа пpогpаммиста и шамана имеет много общего — оба боpмpчyт непонятные слова, совершают непонятные действия и не могут объяснить, как оно работает.
Нородная примета
Народная примета: если программист в 9.00 утра на работе, значит, он там ночевал…
Испугался!
— Вы уверены что хотите удалить папку D:TEMP ?— Да.— В этой папке находятся файлы. Вы уверены что хотите их удалить?— Да!— Удаление этих файлов может повлиять на зарегистрированные программы. Вы все еще уверены?— Да! Да! Да!!!— Эти файлы могут использоваться системой. Вы уверены?— Пошла ты! —
Блондинка и программист
Две версии одного анекдота Версия программистаПрограммист рассказывает своим друзьям, таким же, как он:- Вчера в ночном клубе я познакомился с клевой блондинкой!Друзья:- Ух ты!- Потом я пригласил ее к себе, мы с ней выпили, я начал ее ласкать.- Здорово!- Тут она мне говорит: "Раздень меня!"-
Классификация водки в стиле IT
Классификация водки в стиле IT:0.1л — demo.0.25л — trial version.0.5л — personal edition.0.7л — professional edition.1.0л — network edition.1.75л — enterprise.3л — for small business.5л — corporate edition.Бутыль самогона — home edition.На посошок — Service pack.Рассол с утра — Recovery
Каждой твари по витой паре!
Девиз Сисадмина:Каждой твари — по витой паре!
Админы идут в бухгалтерию чинить принтер!
Бухгалтерша(истерично): ...да и вообще, я твоей работы что-то пока не видела, а значит ее и нет!админ(устало): а мозги свои ты сколько раз видела?
Что такое групповое изнасилование по телефону?Это когда 150 пользователей звонят сисадмину что у них пропал интернет.
Вредоносная программа
Встретились два программиста. Один говорит:— В моей жизни появилась вредоносная программа!— Какая вредоносная программа?— Жена…
Резво подниму твой сервер
Встречаются два системных администратoра,и oдин спрашивает другoгo:- Ты чегo такoй грустный?- Да вoт сервер вчера "упал".- Ну да ты чтo, егo дo сих пoр не "пoднял"?- Пoднял, нo oн сo стoла упал...
Анегдот дня
Хотите превратить свой Core i9 в Core i3? Поставьте себе на машину антивирус Касперского :)  
Анегдоты дня
Если программа работает не так, как написано в инструкции к ней - то ошибка может быть и там, и там. Согласно народной примете, в новый дом первым нужно впускать интернет-кабель. И где он ляжет - там ставьте кровать. И стол. И комп. И жрачку На русификацию новой версии Windоws было потрачено
Не лишайте премии сисадмина
У главного босса фирмы день рождения. Все сотрудники собрались, придумывают ему поздравительную открытку, но ни у кого нет никаких идей, что написать. В это время в комнату заходит сисадмин. Все сразу к нему:- Слушай, что ты можешь сказать про нашего начальника?Сисадмин, не задумываясь, отвечает:-
Анегдоты дня
Инвентаризация в офисе. Секретарша: — Сколько у нас в офисе чайников? — Пятьдесят шесть! И трое более—менее соображающих, — машинально ответил сисадмин. Системный администратор тр@х@ется только тогда, когда у него всё упало. Религия Сисадмина: — Когда бог хочет меня наказать, он лишает
Самое плохое ощущение для программиста
Самое плохое ощущение для программиста — когда вокруг тебя стоят десять человек и все пытаются найти причину проблемы в твоей программе, а ты уже понял, в чём проблема, но боишься сказать, потому что это что-то вопиюще глупое…
Анегдот дня
Сюжет фильма Терминатор 5: Для устранения ошибок и сбоев в системе Скай-Нет в прошлое посылают терминатора, чтобы убить Билла Гейтса.  
Анегдот дня
— Вы уволены!— За что?!— За ошибки в ваших программках.— Не согласен, ошибки есть даже у Билла Гейтса, посмотрите, столько их у него в Офисе!— Не надо валить все на Билла Гейтса. Вы пишите свои программки не для его офиса, а для нашего оперного театра!  
Скромняга
Как-то раз Билла Гейтса спросили:— Какая из операционных систем, когда либо создававшихся человеком,самая лучшая?— UNIX, — не задумываясь ответил Гейтс.— Но… а как же Windows?— Windows создал Бог, — скромно ответил тот.
Разгон процессора
  В жизни есть только три вещи, от которых некуда деться - это смерть,налоги и желание иметь более быстрый процессор!   Встречаются русский, американец и японец, ну и начали спорить у кого технологиикруче. Американец и говорит:- Вот у нас в Америке берем болванку, бац по болванке
Хороший программист
Хороший программист характеризуется умением доказать почему задачу невозможно выполнить когда ему просто лень её выполнять.
Настоящие программисты любят Windows
Настоящие программисты любят Windows: все ошибки, сделанные по собственной тупости, можно свалить на Microsoft.
Повысим квалификацию?
Админы обычно живут в однокомнатных квартирах на окраине Москвы. В квартире есть компьютер, электрический чайник, банка кофе и микроволновка, в которой админ готовит пиццу. Больше админу ничего не нужно.
Срочно в офис
Сидит психиатр у себя в кабинете - скучает...... пациенты не идут.Тут тихонько так приоткрывается дверь и к нему на карачках заползаетчеловек, сжимая что-то в зубах, руках и т.д. плюс что-то ещеволочится сзади.Психиатр:- Ой, кто это к нам тут ползет!!! Это, наверное, маленькая змейка.Заползай,
Сколько программистов нужно чтобы заменить лампочку?
  Сколько программистов нужно чтобы заменить лампочку? Ни одного. Перегоревшая лампочка это аппаратная проблема и програмисты их не решают.
Что такое групповое изнасилование по телефону?Это когда 150 пользователей звонят сисадмину что у них пропал интернет.
Анегдоты дня
Любителям приводить в пример Билла Гейтса как успешного человека, бросившего учебу, стоит помнить, что он бросил Гарвард, а не задрищенское ПТУ. — Исаак, ты слышал, что Тарантино снял «Убить Билла», когда пытался установить у себя Windows XP?— Да, Абраша, а «Убить Билла 2» — когда, наконец, смог
Анегдоты дня
Завещание Билла Гейтса ежемесячно автоматически обновляется. У Билла Гейтса родилась дочь. Назвали «Новая папка».
А какой процессор?
Встречаются два хакера. Один хакер говорит другому:— Вчера встретил такую потрясающую блондинку в ночном клубе.— Да, ты что!— Потом пригласил ее к себе на чашку кофе.— Да ну!— Когда мы вошли ко мне, она полностью разделась.— Ну, а дальше?!— А потом я посадил ее на стол, где стоит компьютер..— У
Анегдот дня
Microsoft заявляет, что Windows Vista совмещает в себе возможности Unix с традиционными преимуществами Windows. И действительно, от Unix/Linux там несовместимость с распространённым железом и софтом, а от Windows - тормоза и глюки!  
Анегдот дня
Жена сисадмина спрашивает мужа: - Почему ты никогда не рассказываешь, как у тебя дела на работе? - Да чего тебе рассказывать? Вот, вчера блок питания сгорел... - Бедненький! Ну ты хоть с собой бутерброды бери.  
Много общего с интернетом!
— Между моей девушкой и Интернетом есть много общего.— Ага, пользователей много.
Мышка тут главная
ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ:Я устанавливаю нелегальную копию и мне наплевать на всякие там лицензии. Будут деньги - куплю официальную а пока поработаю и с этой. На техническую поддержку и прочие прелести цивилизации не претендую.
Анегдот дня
Верну утраченную ОС, сниму вирусную порчу и венец безинтернетия. Снимаю с программ сглаз правообладателей, выполню отворот RIAA, поиск потерянных файлов по имиджу жесткого диска
Игрок
- А y меня вчеpа дpyг за пять минyт сеpвеp сломал.- Он что, хакеp??!- Он мyдак!!
Анегдот дня
— Чем шизофреник отличается от сисадмина?— Первый общается с кофеварками, второй — с чайниками.  
С днём рождения Linux
  Доктор, я страдаю от галлюцинаций. Или проще, у меня глюки. - А какая у Вас операционная система?- Windows.- Могу посоветовать перейти на Linux. Но предупреждаю, глюки должны исчезнуть, но получите геморрой.
Windows 10
Звонок на радио:Поставьте пожалуйста песню Пугачевой про то как у нее завис Windows!ди-джей (после паузы):Я не могу вспомнить у Пугачевой такой песни!Можете напеть?ну там еще в припеве: Кликну а в ответ тишина снова я осталась одна Сильная женщина плачет у Окна
Как открыть UDP сокет?
Если синхронизировать скорость чтения и записи, то можно случайно открыть UDP сокет.
Пожалуйста, не выгоняйте студентов из Гарварда.
Пожалуйста, не выгоняйте студентов из Гарварда. Дайте им доучиться. А то они потом Windows делают.
Анегдот дня
Переустановка Windows - как разморозка холодильника. Помогает, но ненадолго..  
Уменя всё работает
Настоящий программист как известно, ставит рядом с собой 2 стакана - один с водой, на случай если захочет пить, другой без воды, на случай, если не захочет.А вот настоящий админ ставит четыре стакана. Другие два - на случай отказа первой системы.
Переходная ступень между неандертальцем и программистом
Разговор о системах счисления:— Программист подарил своей женщине 5 роз, сказав "эта 101 роза тебе" (двоичная). Пещерный человек, подарил бы три розы, сказав "бери эти 111 роз" (унарная).— То есть неандертальца от программиста отличает всего лишь ноль?— Ну вообще введение 0 было огромным шагом для
Иерархия
У парня спрашивают об отошениях с его девушкой.Мамаша: "У тебя с ней серьезно?".Программист: "Вы с ней уже какие-нибудь ресурсы делите?".Системный администратор: "Какие права доступа ты на неё уже имеешь?".
Анегдоты дня
Идёт сисадмин, несёт бутылку вина. Его спрашивают: — Откуда? Он: — Да в конторе одной починил принтер. факс, ещё кое—что… — «Кое—что» — это ты говорить не хочешь или сам не знаешь, что починил?   Если бы сисадмины работали в МЧС: — Приезжайте, здесь желтая двенадцатиэтажка
Анегдот дня
Что делает сисадмин, просыпаясь после дикой пьянки?— Тестирует память…
Анегдот дня
1) Со слов менеджера: -Hе включается компьютер - зову админа. Админ приходит, воздевает руки к небу, бормочет про себя невнятные слова, поворачивает мой стул 10 раз вокруг своей оси, пинаеткомпьютер - тот начинает работать. Вновь воздевает руки к небу, что-то бормочет, уходит. 2) Со слов
Трудолюбивый сисадмин
 Корпоратив. Турбаза. Домик с русской печкой. с охапкой дров входит наш админ. В голове тут же мысль: "всё правильно - пришёл админ, принёс дрова..."
Свадьба сисадмина
Жена - засыпающему мужу-админу:- Милый, прохладно – я закрою окно?- Не закрывай, просто сверни его…
Сисадмин всегда прав
Друзья дарят сисадмину на день рождения чемодан. Сисадмин говорит:- Спасибо, конечно, но нафига он мне?- Ну ты же в командировки по работе ездишь, чтобы системки настраивать?- Ну, езжу.- Так будешь вот сюда трусы класть, вот в этот кармашек - носки, сюда - рубашку, а вот сюда...- Подождите, ребята!
Хочу ребёнка!
Жена пpогpаммеpа говоpит мужу:— Дорогой, я хочу ребенка!— Ложись, ща пpоинсталлиpуем!
Анегдот дня
Потомственный системный администратор Сергей. Очное и заочное (по IP-адресу) лечение компьютеров. Гадание по портам (COM, LPT, USB).  
Сисадмин в бухгалтерии
- Сегодня гость нашей студии — знаменитый дрессировщик коров Иванов Петр Сергеевич! Петр Сергеевич, ваш номер поражает своей необычностью, ведь всем известно, что коровы необычайно тупые животные и дрессировке не поддаются. Как вам удалось добиться таких успехов?- Легко. Видите ли, до того как
На самом деле это его идея
Звонок на фирму которая занимается ремонтом компьютеров:— Мой принтер начал плохо печатать!— Вероятно его надо просто почистить. Это стоит 50. Но для вас будет лучше если вы прочтете инструкцию и выполните эту работу сами.Клиент удивленный такой откровенностью спрашивает:— А ваш босс знает что вы
Работа с фрилансером
Фрилансер – это сбежавший от барина офисный работник.   В школе узнали про текстовые биржи. Теперь школьники пишут сочинения на тему: «как установить пластиковые окна».   – Здравствуйте! Мне надо то, не знаю что, там, не знаю где, за сколько, не знаю сам! – Это вам,
Компьютеризмы
И сисадмины скачивают порнуху. Каждая мышка должна знать свой коврик. Если Windows больше нечего сказать, он посылает всех на три клавиши. И лицензионный Windows глючит. Троянский конь всегда найдет ахиллесову пяту вашего компьютера. Хороший сисадмин никогда не перепутает дисковый Raid от Raid
Объявление:В магазин всё для системного администратора поступили в продажу бубны и шаманские тотемы! Ассортимент огромен, наши цены Вас приятно удивят.
Женщины, как web-сервер
Женщины, как web-сервер 400 Ваd Rеquеst — свидание без букета.401 Unаuthоrizеd — замужем.402 Рауmеnt Rеquirеd — ужин при свечах.403 Fоrbiddеn — я знать тебя больше не хочу!404 Nоt Fоund — сегодня я гуляю с подругами.405 Меthоd Nоt Аllоwеd — нет, только не сзади….407 Рrоху Аuth. Rеquirеd — мне
Анегдоты дня
Разговаривают два сисадмина: — Чертова работа… Позавчера ушел в 3 часа ночи, вчера ушел в час ночи… — Что, вчера отпросился?    Не ругайте Господа нашего. Представьте сеть, в которой 6 миллиарда юзеров. А каково быть там сисадмином?    На следующий день после
Ничего не меняй!
Сидит программист глубоко в отладке. Подходит сынишка:— Папа, почему солнышко каждый день встает на востоке, а садится на западе?— Ты это проверял?— Проверял.— Хорошо проверял?— Хорошо.— Работает?— Работает.— Каждый день работает?— Да, каждый день.— Тогда ради бога, сынок, ничего не трогай, ничего
Сама я не месная
- Ты Фотошопить умеешь?- Не, только Корелдрочить.
Анегдоты дня
Объявление в Интернете: Куплю винчестер. Жёсткие диски не предлагать! Кликуха - это не то, что вы подумали, а компьютеpная мышь!
Твой кролик написал - Your Bunny Wrote
Американские программисты очень долго не могли понять почему их pyсские коллеги пpи зависании Windows всё время повторяют фpазy твой кролик написал (Your Bunny Wrote) (английский вариант следует прочитать быстро).
Высказывания про админов
Высказывания про админов: Админ спит — значит, все системы работают! Админ не заснул, он перегружается! Не верь трудолюбивому Админу! Ибо только лень заставит его настроить систему раз и навсегда! В отличии от Windows Админ не многозадачен! Если Админ затрудняется расписаться в получении
Шаманхуев
Однажды молодой сисадмин познакомился с веб-дизайнершей. По привычке он сразу же спросил, какой у нее iр-адрес, но услышав, что IP-адрес у нее динамический, тут же потерял к ней всякий интерес.
Нужна сиделка!
Для ухода за пожилым программистом требуется приятная женщина, говорящая на FORTRAN, BASIC и С++.
Анегдот дня
- Чем отличается программист от политика? - Программисту платят деньги за работающие программы.
Программа не продаётся
У сисадмина спрашивают:- А вы часто по порносайтам ползаете?- Нет, все необходимое в кэше нахожу.
«
»
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • 107
  • 108
  • 109
  • 110
  • 111
  • 112
  • 113
  • 114
  • 115
  • 116
  • 117
  • 118
  • 119
  • 120
  • 121
  • 122
  • 123
  • 124
  • 125
  • 126
  • 127
  • 128
  • 129
  • 130
  • 131
  • 132
  • 133
  • 134
  • 135
  • 136
  • 137
  • 138
  • 139
  • 140
  • 141
  • 142
  • 143
  • 144
 rss  vk groupe

 

Нравится ли вам наш блог?

Услуги по удалённой настройке MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промзвязь в Минске
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3


Shuttle модернизировала свои 1,3-литровые ПК
В линейке компьютеров DS10 компания Shuttle теперь предлагает четыре тонких корпуса без вентилятора. Все модели DS10 не имеют вентиляторов и работают без шума. В то же время они требуют минимального
Philips выпускает монитор 439P9H с соотношением сторон 32:10
Компания MMD, занимающаяся выпуском мониторов под брендом Philips, анонсировала поступление в продажу сверхширокой модели 439P9H. Она базируется на 43-дюймовой изогнутой матрице VA с разрешением 3840
Sony начинает исследования в сфере искусственного интеллекта с создания соответствующего подразделения
Sony Corporation официально объявила о создании нового подразделения Sony AI. Оно будет иметь офисы в Японии, Европе и США, а основное направление его деятельности будет связано с проведением
Через месяц пользователи Windows 10 Mobile и Windows Phone останутся без WhatsApp
Как известно, поддержка Windows 10 Mobile прекратится уже в декабре. А компания Facebook решила сделать пользователям ещё один «сюрприз» к праздникам. Сообщается, что с 31 декабря 2019 года
«Яндекс» представил новую камеру слежения за водителями
Глава Минтранса Евгений Дитрих рассказал, что российская компания «Яндекс» представила новую камеру, способную следить за состоянием водителей на дороге и предотвращать ДТП в случае необходимости.
Apple работает над приложением для Windows 10 на смену iTunes
Ранее в этом году компании Apple отказалась от магазина iTunes для системы macOS, разделив его на три отдельных приложения Podcasts, Music, Apple TV. В тот момент компания утверждала, что iTunes на
Мошенники от имени Microsoft заражают компьютеры пользователей вирусом-вымогателем
Компания Microsoft то и дело устраивает своим пользователям сюрпризы, размещая плохо работающие обновления, содержащие множество багов и недоработок. Кажется, что уже одного этого должно быть
Signify внедряет связь Li-Fi на основе световых волн в автобусах и самолётах
Технология связи Li-Fi на основе световых волн получает всё более широкое распространение благодаря простоте и дешевизне реализации, отсутствию радиодиапазона и возможности применения, например, на
«
»
  • 1
  • 2

Авторизация