fb logo  VK  Feed icon.svg  

Звоните нам: +375 (29) 6487878, +375 (29) 7733778, +375 (25) 9997887

Переключение маршрутов на MikroTik при пропадании пинга к хосту

опубликовал от 19 Май, 2014

Существует простая схема резервирования соединений с интернетом установкой разной метрики на маршруты и опрос шлюза пингами или арпами для проверки его доступности. Но иногда для соединения с провайдером используется специфичный роутер устанавливающий специфичный протокол тунелирования. Те же 4G модемы YOTA являются маршрутизаторами с USB интерфейсом не всегда совместимы с MikroTik. Для работы с ними приходится использовать промежуточные маршрутизаторы, которые будут пинговаться даже если интернет пропадёт в сети YOTA.

В этом случае создаются марки маршрутов на хосты с высоким тайм апом. Например: 8.8.8.8, 8.8.4.4, 77.88.8.8, 77.88.8.1

Создаём основной маршрут на хост 0.0.0.0/0 с марком route-gw1 и коментарием kam_gw1. Комментарий необходим так как в будущем невозможно обратится к номеру маршрута командой ввиду того, что они меняются. Приходится искать скриптом комментарий.

/ip route
add check-gateway=ping comment=kam_gw1 disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=192.168.0.1 routing-mark=route-gw1 scope=30 target-scope=10

Само собой должен быть и дополнительный маршрут на шлюз 192.168.1.1 который будет работать при отключении первого:

/ip route
add check-gateway=ping comment=kam_gw2 disabled=no distance=5 dst-address=\
0.0.0.0/0 gateway=192.168.1.1 routing-mark=route-gw1 scope=30 target-scope=10

Создадим контрольный маршрут для роутера к хосту 8.8.8.8 c марком route-1. Смысл в том что если будет пропадать/появляться пинг к хосту 8.8.8.8 c маршрутизатора NetWatch будет переключать маршрут для пользователей интернета с коментарием kam_gw1

/ip route
add check-gateway=ping comment=kontrolnij disabled=no distance=1 dst-address=\
8.8.8.8/32 gateway=192.168.0.1 routing-mark=route-1 scope=30 target-scope=10

Создадим правило маршрутизации в ip route rules для таблицы route-1 и это сделает таблицу маршрутизации для самого роутера однозначной.

Создадим проверку 8.8.8.8 в netwatch на доступность c правилами на падение и подъём хоста:

выключаем маршрут c комментарием kam_gw1 если пинг пропадает:

ip route set [find comment=kam_gw1] disable=yes 

включаем первый маршрут c комментарием kam_gw1 если пинг появляется:

ip route set [find comment=kam_gw1] disable=no

 

 

Прочитано 15421 раз Последнее изменение Вторник, 28 Март 2017 03:13
Кардаш Александр Владимирович

Автор статей по настройке сетевого оборудования. Добрый айтишник!

Сайт: https://netflow.by

Другие материалы с нашего сайта:

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим. Сообщения проходят модерацию и могут быть не опубликованы, если не являются осмысленными или содержат в тексте бесполезную ссылку на другой сайт...

Комментарии к статьям:

  • Максим Кушнаренко Написал Максим Кушнаренко Июль 06, 2019 Поскольку пользователи социальных сетей используют соединения HTTPS, которые выхватить гораздо сложнее, то необходимо использовать новую…
  • bcloud Написал bcloud Июнь 17, 2019 Добрый день! Подскажите, пожалуйста, как решить проблему. У нас на фирме подключили такой модем, все…
  • Нур Написал Нур Апрель 30, 2019 работает на локалке, а по wifi на телефоне не работает
Услуги переустановки Windows с выездом по Минску
Установка Windows в Минске на ПК и MAC весьма востребованная услуга. Часто ввиду заражения вирусами или вредоносными программами, а также после случайно удаления системных файлов, операционная
Услуги по настройке маршрутизаторов MikroTik
Полноценное использование маршрутизатора MikroTik достигается только в результате его грамотной настройки. Неопытный специалист может очень долго провозиться с маршрутизатором, так и не заставив его
Услуги настройки Wi-Fi сети в Минске
Настроим любые Wi-Fi роутеры с выездом к вам. Современные компьютерные технологии предлагают пользователю все новые достижения, способные сделать работу с компьютером и сетью Интернет удобнее,
Услуги ремонта компьютеров с выездом по Минску
Каждый из нас хоть раз сталкивался с неожиданной поломкой компьютера, его комплектующих, или же выхода из строя программного обеспечения. Зачастую, это происходит в самый неподходящий момент: когда
Услуги восстановления данных в Минске
Hаши специалисты смогут помочь Вам восстановить информацию с выездом по Минску. Опытные сотрудники нашей компании помогут вернуть важные данные, соблюдая конфиденциальность и ваши интересы.
Услуги по настройке модемов Промсвязь
Настроим роутеры белорусских интернет провайдеров с выездом по Минску. Сегодня многие пользователи знакомы с беспроводными сетями, знают о преимуществах их использования. Однако дома у
«
»
  • 1
  • 2
  • 3
 rss  vk groupe

 

Нравится ли вам наш блог?


Обнаруженная в протоколе Bluetooth дыра позволяет прослушать миллионы устройств
В протоколе Bluetooth обнаружена новая уязвимость. Исследователи Даниель Антониоли (Daniele Antonioli), Нильс Оле Типпенхауэр (Nils Ole Tippenhauer) и Каспер Расмуссен (Kasper Rasmussen) обнаружили,
Власти США могут на 90 дней отложить санкции против Huawei
США уже не скрывают, что запрет на работу с китайской компанией Huawei ― это всего лишь инструмент экономического давления на власти Поднебесной. Всё начиналось с заявок об угрозе национальной
Разработчики говорят, что ограничения Apple на отслеживание местоположения являются антиконкурентными
Группа разработчиков приложений для iOS занялась новыми политиками конфиденциальности Apple, которые дебютируют вместе с iOS 13 этой осенью. Они заявляют, что ограничения отслеживания местоположения,
ФАС оштрафует Google за «ненадлежащую» контекстную рекламу финансовых услуг
Федеральная антимонопольная служба России (ФАС России) признала контекстную рекламу финансовых услуг в сервисе Google AdWords нарушающей требования Закона о рекламе.  Нарушение было
iPhone 11 скорее всего выйдет 10 сентября
10 сентября Apple скорее всего представит минимум три новых смартфона. Об этом говорит картинка найденая в IOS 13 Beta. Скорее всего, их назовут iPhone 11, iPhone 11 Pro и iPhone 11 Pro Max.
Нехватка процессоров Intel сохранится до 2020 года
По данным тайваньского ODM-производителя Compal Electronics, нехватка процессоров Intel продолжится во втором полугодии этого года и сохранится до начала 2020 года. В конце прошлого года Intel
Apple будет враждебно относиться к сайтам, нарушающим правила конфиденциальности Safari
Компания Apple заняла жёсткую позицию в отношении веб-сайтов, которые отслеживают и передают третьим лицам историю посещений пользователей. В обновлённой политике конфиденциальности Apple говорится о
Искусственный интеллект стартапа оказался группой индийских программистов
Некоторое время назад индийский стартап Engineer.ai заявил о создании платформы на базе ИИ, способной самостоятельно создавать приложения. Но на деле он оказался командой
«
»
  • 1
  • 2

Авторизация